1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

what psp model should i get?

Discussion in 'Sony PSP - Mod and firmware discussion' started by terr0r69, Oct 26, 2011.

  1. terr0r69

    terr0r69 Member

    Joined:
    Mar 23, 2011
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    11
    hello everyone,
    i am planning to buy a sony psp next month and i am wondering for sake of modding it, wich one should i try to get? im not intrested in the psp go. and should i get it from ebay, or gamestop? im shure this is outdated,but i downloaded the "magic memory card maker" program and have a real pandora battery, but i think i got the wrong battery as the one they sent me is for a "slim" psp can i still use this for my psp mod? thanks for any and all replys i get................terr0r69
     
  2. Eisherz

    Eisherz Active member

    Joined:
    Nov 28, 2006
    Messages:
    2,826
    Likes Received:
    31
    Trophy Points:
    78
    If you want it to be 100% surely modable get a PSP 1000 off ebay. Or get a PSP 2000, but then you got a chance to get one that is not permanently modable with a pandora battery. You can still use non-permanent firmwares on these. A PSP 3000 isn't pemanently modable at all (exept for the so-called "perma-patch" for 6.20 firmwares, which is pretty outdated).
    The problem with the 1000 models is that the one you get can be six to seven years old, these models start failing. Also for a 1000 you would need another pandora battery (btw: Pandora battery is only for fixing these days, you don't really need one for modding anymore). If you get a PSP 2000 from gamestop maybe they let you test the PSP with your pandora battery and your magic memory stick first, the pandora battery you already have, with the magic memory stick maker you also have you can create that magic memory stick (1 or 2 GB sticks work best, as far as I know).
     
  3. acest69

    acest69 Member

    Joined:
    Oct 27, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    ok if anyone can help it would be awesome i have a psp phat with firmware of3.80 m33-5 i have umd emulator it seems like older games will play isos fine but newer games will load but stay on a black screen any thoughts thank you
     
  4. Eisherz

    Eisherz Active member

    Joined:
    Nov 28, 2006
    Messages:
    2,826
    Likes Received:
    31
    Trophy Points:
    78
    Go to 6.60 ME. By the way, you don't need the umd emulator, that thing is so outdated, most people here won't even remember it.
     
  5. tymarski

    tymarski Regular member

    Joined:
    Jan 16, 2009
    Messages:
    172
    Likes Received:
    0
    Trophy Points:
    26
    Hmm, Eisherz may I ask something?

    What is the difference of 6.60ME and 5.50 prome-4? Because I just found my psp w/ 5.50 prome-4.
     
  6. acest69

    acest69 Member

    Joined:
    Oct 27, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    ok thanks problem solved thankyou much
     
  7. Eisherz

    Eisherz Active member

    Joined:
    Nov 28, 2006
    Messages:
    2,826
    Likes Received:
    31
    Trophy Points:
    78
    6.60 ME is the latest firmware, allowing you to play all games and also to go online (PSN).
     

Share This Page