1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

what should i do

Discussion in 'Sony Handhelds' started by mjfouline, Aug 16, 2007.

  1. mjfouline

    mjfouline Guest

    should i buy an old psp or shopuld i just get the new psp slim comin out next month.

    are they boht the same like are they both goin to get the same games or will the psp slim get newer ones and the old psp not get them
     
  2. XEnigmaX

    XEnigmaX Regular member

    Joined:
    Jun 16, 2006
    Messages:
    639
    Likes Received:
    0
    Trophy Points:
    26
    If you want to use the PSP like it's supposed to be used (legally), then get the Slim.

    If you want to have fun with your PSP, by installing homebrew applications and playing PSX games, then get an older one. If you do get an older one, try to make sure that it's firmware is lower than or equal to 3.50. (to check, once you have the PSP, go all the way left, select system settings, then select system information. It'll say what you have here). If you can get 2.71 or lower, it'll be easiest to play homebrew applications. If you get higher than 2.71, then make sure you buy the game Lumines.
     
  3. mjfouline

    mjfouline Guest

    thx

    yea im gettin a 3.4 from my freind and im gettin gamefly and hopin for the best with lumines from there.
     
  4. mjfouline

    mjfouline Guest

    Well one more thing so your saying all the games will be the same on each console.

    i know all about homebrew but im just worried about the games and stuff
     
  5. XEnigmaX

    XEnigmaX Regular member

    Joined:
    Jun 16, 2006
    Messages:
    639
    Likes Received:
    0
    Trophy Points:
    26
    Yeah, sony's not going to be stupid and make the games non-interchangeable.
     
  6. mjfouline

    mjfouline Guest

    thx man
     

Share This Page