1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

What should i put on my 1.5 PSP?

Discussion in 'Sony PSP - Mod and firmware discussion' started by dansage, Apr 8, 2007.

  1. dansage

    dansage Regular member

    Joined:
    Jan 14, 2006
    Messages:
    327
    Likes Received:
    0
    Trophy Points:
    26
    Hi,

    Been away from the PSP scene now for about 6 months.

    Just bought another psp (V2.0) and have downgraded to 1.5, all new and shiny.

    What would you guys reccommend i put on it firmware wise?

    And whats this new custom firmware all about?

    Any help would be great,

    Thanks

    Dan.
     
  2. ps2gen

    ps2gen Regular member

    Joined:
    Aug 23, 2006
    Messages:
    455
    Likes Received:
    0
    Trophy Points:
    26
    id suggest getting psp custom firmware V3.03OE C, Or V3.10OEA ( Rev 2 Edition)

    The reasons are basically endless lol, but here are some of the major points which causes people to install it:

    The ability to play PS1 games without the need of ps3
    To play UMD Games which require v2.82 + firmware and still be able to play homebrew

    As i said the possibillities are endless, go to Dark AleX's website to find out more
     
  3. dansage

    dansage Regular member

    Joined:
    Jan 14, 2006
    Messages:
    327
    Likes Received:
    0
    Trophy Points:
    26
    Thats great,

    Ive just downloased version C. Does this oe still run iso's and cso's without needing devhook etc?

    I'll look on alex's website.
     
  4. ps2gen

    ps2gen Regular member

    Joined:
    Aug 23, 2006
    Messages:
    455
    Likes Received:
    0
    Trophy Points:
    26
    Absolutely, all you need is ZiNgaBuRga's POPSTATION (POPS to convert your psx/1 games to be played on psp
    As for psp iso's, no devhook is needed at all. Just place the ISO/CSO in the PSP GAME FOLDER as you probably already know.
     
  5. MidnightJ

    MidnightJ Guest

    You should put the 3.03 OE-C update on there.
     
  6. ps2gen

    ps2gen Regular member

    Joined:
    Aug 23, 2006
    Messages:
    455
    Likes Received:
    0
    Trophy Points:
    26
    On where? hes already download the 3.03 oec
     
  7. dansage

    dansage Regular member

    Joined:
    Jan 14, 2006
    Messages:
    327
    Likes Received:
    0
    Trophy Points:
    26
    Thanks for all your help,really,

    My mate is interested and he needs to know, can ANY firmware version support the new OE firmwares? and if so how do you downgrade to 1.5?

    ie, if he buys a new psp, can the latest firmware be downgraded.

    Thanks again.
     
  8. ps2gen

    ps2gen Regular member

    Joined:
    Aug 23, 2006
    Messages:
    455
    Likes Received:
    0
    Trophy Points:
    26
    Nah, all firmwares can be downgraded apart from 3.10 and 3.30,
    theres a guide on here somewhere telling you how to tell what version the psp will be before you buy it by looking at the serial number on the box...
    id have posted the link but im putting a heavy load of homebrew etc on ma psp and u know, kinda busy, but search or look at some stickys on the psp forum sections, it will be there somewhere

    Glad to be of assistance
     
  9. dansage

    dansage Regular member

    Joined:
    Jan 14, 2006
    Messages:
    327
    Likes Received:
    0
    Trophy Points:
    26
    Great help,

    Thanks.
     
  10. ps2gen

    ps2gen Regular member

    Joined:
    Aug 23, 2006
    Messages:
    455
    Likes Received:
    0
    Trophy Points:
    26
    Its Cool
    No Problemas
     
  11. dansage

    dansage Regular member

    Joined:
    Jan 14, 2006
    Messages:
    327
    Likes Received:
    0
    Trophy Points:
    26
    Ok,

    I got confused. My friend has a PSP with version 3.01, what does he need to do to downgrade, (he has copy of GTA)

    Thanks
     
  12. gasconade

    gasconade Regular member

    Joined:
    Feb 17, 2007
    Messages:
    862
    Likes Received:
    0
    Trophy Points:
    26
  13. dansage

    dansage Regular member

    Joined:
    Jan 14, 2006
    Messages:
    327
    Likes Received:
    0
    Trophy Points:
    26
    WOW! that was quick, you guys are on the ball!

    Does the guide tell me how to check for the correct version of LCS? and doesn't the motherboard issue (ta 82) exist anymore?

    (As mentioned before, i have been away from the psp scene for a while, and when i left, the 2.6 downgrader had only just come out, but if you had a ta 82, you were screwed!)

    Ta again

    Dan
     
  14. ggbarnum

    ggbarnum Regular member

    Joined:
    Apr 14, 2006
    Messages:
    1,432
    Likes Received:
    0
    Trophy Points:
    46
    The 3.03 downgrader works on all mobo's

    [EDIT] remember if he is on 3.1 you will need to upgrade to 3.03 before downgrading
     
    Last edited: Apr 8, 2007
  15. gasconade

    gasconade Regular member

    Joined:
    Feb 17, 2007
    Messages:
    862
    Likes Received:
    0
    Trophy Points:
    26
    absolutely correct.....the dg patches all mobos ta or non...

    side note: ive heard rummors of patched mobos not being able to run 3.30 sony.....not like it matters, cause once you get a custom fw on your psp, all you have to do is wait for DAX to drop the newest OE...
     
  16. dansage

    dansage Regular member

    Joined:
    Jan 14, 2006
    Messages:
    327
    Likes Received:
    0
    Trophy Points:
    26
    crikes! i didn't realise how far things had come the last few months.

    is there any way of telling a correct GTA LCS by looking at the case?
     
  17. gasconade

    gasconade Regular member

    Joined:
    Feb 17, 2007
    Messages:
    862
    Likes Received:
    0
    Trophy Points:
    26
  18. dansage

    dansage Regular member

    Joined:
    Jan 14, 2006
    Messages:
    327
    Likes Received:
    0
    Trophy Points:
    26
    Superb once again.

    I can see many hours being lost on this forum in the next few months!!!

    Anything else worth putting on?
     

Share This Page