1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Which PS2 is compatible with HD Advance and Swap Magic 2.0?

Discussion in 'PS2' started by VJbob, Oct 15, 2004.

  1. VJbob

    VJbob Regular member

    Joined:
    Oct 6, 2004
    Messages:
    297
    Likes Received:
    0
    Trophy Points:
    26
    I'm thinking of buying a new PS2 but I want to get a version that is both compatible with HD Advance and Swap Magic 2.0 (if thats not possible I'll go get Swap Magic 3.0). How can I tell, without opening the box, what version a PS2 is and what version would anybody recommend? My first generation version keeps overheating and its really frustrating.
     
  2. bmx3697

    bmx3697 Member

    Joined:
    Oct 13, 2004
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    16
    Did you check www.hdadvance.com for your answers?
    "HDAdvance is NOT compatible with the following Japanese PS2 models: SCPH 10000, SCPH 15000 and SCPH 18000."
    Probably easier for them to state the models it's not compatible with... I believe(just what I think I read somewhere) that the only reason it's not compatible with them is because the network adapter doesn't fit, or something along those lines.
    So anyways, long answer to a short question: All versions except the obvious new PSTwo.
     

Share This Page