1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Which swap disk version do I need?

Discussion in 'PS2 - DVD backup discussion' started by Bluesplar, Nov 9, 2004.

  1. Bluesplar

    Bluesplar Member

    Joined:
    Oct 26, 2004
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    11
    I had to cancel my order with ps2cover.com because those people are incompetent. I have a newer model ps2 ver. 9 or 10 i believe. I'm looking at the different sites and some say that the ver. 3 swap disks won't work with my model. Which ones do I get then? Any help is greatly appreciated.
     
  2. sly_61019

    sly_61019 Senior member

    Joined:
    Jun 28, 2003
    Messages:
    9,522
    Likes Received:
    0
    Trophy Points:
    116
    wait a little bit (or it might be out already), the new 3.3 version of swap magic is comming out.
     
  3. yugioh2me

    yugioh2me Regular member

    Joined:
    Jun 22, 2004
    Messages:
    509
    Likes Received:
    0
    Trophy Points:
    26
    i thought that the V3.2 CD Disk for Swap Magic should work with the V9 and V10 models
     
  4. sly_61019

    sly_61019 Senior member

    Joined:
    Jun 28, 2003
    Messages:
    9,522
    Likes Received:
    0
    Trophy Points:
    116
    Yeah, the 3.2 disc will work, but might as well get 3.3.
     
  5. yugioh2me

    yugioh2me Regular member

    Joined:
    Jun 22, 2004
    Messages:
    509
    Likes Received:
    0
    Trophy Points:
    26
    well ya, thats true since it is coming out in 2 weeks anyways.
     

Share This Page