1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Widescreen movies that stretch vertically

Discussion in 'Blu-ray' started by genz0d, Aug 20, 2013.

  1. genz0d

    genz0d Newbie

    Joined:
    Aug 20, 2013
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I apologize in advance if this subject has been covered before, though I'm not finding anything pertaining to my issue with the forum's search feature.

    I have a series of widescreen 720p bluray rips that play back perfectly on my PC, though when testing them on three different media players and three different 16:9 televisions, the movie is vertically stretched to fullscreen, which is unwatchable. It seems that no matter what I try with the output settings for my media players as well as the televisions themselves, I cannot get black bars to appear at the top and bottom of the screen.

    Is it possible that the black bars were omitted by the person that encoded the mkv? If so, I don't quite understand what the benefit would be - to my knowledge, black bars should never be cropped out when encoding videos. At least that's what I've read and heard from several folks over the last few years. Is it possible to losslessly correct this issue by remuxing the mkv, perhaps with Handbrake?

    Thanks for your time.
     
  2. attar

    attar Senior member

    Joined:
    Jun 17, 2005
    Messages:
    11,511
    Likes Received:
    29
    Trophy Points:
    128
    MkvMergeGUI, part of MKVtoolNix has a setting for aspect ratio.
    You would run the GUI, load the source, highlight the video stream in the lower pane.
    Click the tab for 'Format specific options' and set the AR.
    Start muxing.
    http://www.videohelp.com/tools/MKVtoolnix

    If that doesn't help, there is a Bluray forum at the VideoHelp site
     
  3. genz0d

    genz0d Newbie

    Joined:
    Aug 20, 2013
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Thank you. I'm going to try this in just a bit.
     
  4. genz0d

    genz0d Newbie

    Joined:
    Aug 20, 2013
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Okay, that worked wonderfully. I used MediaInfo to determine the aspect ratio (2.40:1)and input that into mkvmerge's aspect ratio field (2.40). Remuxing took less than 4 minutes on an aging quadcore system. This resolved my issue.

    I hope others that have been puzzled by this see this thread.

    Cheers!
     
  5. genz0d

    genz0d Newbie

    Joined:
    Aug 20, 2013
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Just wanted to add something. Using mkvmerge GUI to correct the aspect ratio could result in files that no longer seek or use chapters correctly with media players. Apparently, this is caused by a known bug. I was able to correct this by remuxing the original source file again, but using this commmand line parameter:

    --clusters-in-meta-seek --engage no_cue_duration --engage no_cue_relative_position

    It was suggested in this thread:

    (edit: huh, new users aren't allowed to post links - it's in a thread at videohelp.com)

    To do this, launch mkvmerge GUI (Im using v6.3.0) and click on "Muxing" in the main menu, then "Add Command Line Options". In the "Command line options" field, paste in the command line above and click OK. You may want to set this as the default for new jobs.

    This works perfectly for me.
     
  6. attar

    attar Senior member

    Joined:
    Jun 17, 2005
    Messages:
    11,511
    Likes Received:
    29
    Trophy Points:
    128
  7. genz0d

    genz0d Newbie

    Joined:
    Aug 20, 2013
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Yes, that's the one.
     

Share This Page