1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Wii with no display video output!

Discussion in 'Nintendo Wii / Wii U' started by Tommy_PF, Dec 22, 2007.

  1. Tommy_PF

    Tommy_PF Member

    Joined:
    Dec 22, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    Has anyone been able to sort out the "no video output" problem with Wii's? I have one which a friend gave me to try and sort out. When you turn it on it sounds ok but there is no display on the TV or sound. If you insert a disc it takes it but it doesn't spin up, but if there is a disc already in the drive when you boot it up the disc will spin... Has anyone had this problem or have any idea how to fix it?

    Any help would be great!

    Tommy
  2. AfterDawn

    AfterDawn Advertisement

  3. rach2k

    rach2k Member

    Joined:
    Dec 13, 2005
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    11
    I brought my wii to play at the in-laws this christmas, and i've got a similar problem - no display. The tv recognises that the wii is plugged into it, but I get no picture at all. Is this fixable?!
  4. Tommy_PF

    Tommy_PF Member

    Joined:
    Dec 22, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    I'm sure it is, could be a blown fuse. I'm going to pull the board out and check all the fuses, if I find the prob I'll post back.
  5. rach2k

    rach2k Member

    Joined:
    Dec 13, 2005
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    11
    Thanks.

    I've talked to Nintendo support, and they've said they'd probably still fix it under warranty, even though it's over a year old. The problem is, a friend chipped it for me, and he's out of the country now. Obviously I can't send it in with the chip in, but I'm nervous of opening it up myself. Is there any list of people who mod wiis, so I can get this sorted out?

Share This Page