1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Wiikey updates necessary to play originals?

Discussion in 'Nintendo Wii / Wii U' started by zorantor, Jan 21, 2008.

  1. zorantor

    zorantor Member

    Joined:
    Jan 21, 2008
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    11
    I'm going to be installing a Wiikey in my NTSC U console, primarily for the purpose of playing Japanese games. I have very little interest in playing backups.

    Is it correct that the Super Mario Galaxy update was only necessary in order to play backups of the game?

    My question is, if I'm only planning to play originals, will I still need to download updates such as the SMG update?
     
  2. wiichess

    wiichess Regular member

    Joined:
    Sep 17, 2007
    Messages:
    571
    Likes Received:
    0
    Trophy Points:
    26
    That depends what updates your talking about. Nintendo give updates in game for those who dont have internet connections with their wii's and to add other features. SMG required you to update your firmware(wii update) to 3.1 to play the game.

    Wiikey updates
    Because SMG have a new type of copyright protection people with wiikeys with 1.9b and lower were not able to play SMG.
    That is why now the 1.9g or 1.9g beta hotfix, lets the wiikey to bypass the new protections.

    But no Wiikey updates have nothing to do with Originals. Wiikey updates are for Backup discs.
     
  3. zorantor

    zorantor Member

    Joined:
    Jan 21, 2008
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    11
    Okay, thanks for the info, but just to make sure I have this straight:

    Is the 1.9g update necessary to play even originals of SMG, or is it only needed to play backups?

    If I install my Wiikey, will I still be able to play my original of SMG, as well as all other originals, without regular updates? Or will my Wii (which has already been updated by SMG) become unusable unless I update with 1.9g?
     
  4. sparkz197

    sparkz197 Member

    Joined:
    Jan 20, 2008
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    11
    Check here for cross region compatibility.....

    http://wiki.gbatemp.net/index.php?title=Wii_Region_Patcher_Compatibility_List

    If you have a US Wii and boot a Jap version of SMG, it will ask you to perform an update. If your Wii firmware is not already at the latest version 3.1u (u=usa) then you could easily end up bricking your console. Better to update via the internet or a copy of SMG from your consoles region.

    You will need to update your Wiikey firmware to 1.9g to play SMG in any case.
     

Share This Page