1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WOW help!!!

Discussion in 'Windows - Games' started by furryboo, Jan 16, 2007.

  1. furryboo

    furryboo Regular member

    Joined:
    Jul 8, 2005
    Messages:
    106
    Likes Received:
    0
    Trophy Points:
    26
    Hi there,
    Just got world of warcraft, raring to go with it but everytime I log and it goes in game, it plays for about 5 - 10 secs and then crashes but to desktop with no message or anything?

    Can anyone help solve this for me? Will getting burning crusade sort it out?

    Cheers for any help.

    Da_Boo
     
  2. chubbyInc

    chubbyInc Regular member

    Joined:
    Apr 27, 2005
    Messages:
    399
    Likes Received:
    0
    Trophy Points:
    26
    Details on your PC?


    Maybe you need a better graphics card
     
  3. furryboo

    furryboo Regular member

    Joined:
    Jul 8, 2005
    Messages:
    106
    Likes Received:
    0
    Trophy Points:
    26
    Mate Athlon XP2800, ATI 128Mb 9800 graphic card, 1Gb of ram.....erm.....

    All fine, all fan atc are working inside....

    Can you help?

    cheers

     
  4. xboxmadd

    xboxmadd Member

    Joined:
    Dec 12, 2005
    Messages:
    82
    Likes Received:
    0
    Trophy Points:
    16
    furryboo i know nothing about World Of Warcraft..

    But i had the same problem with another game of mine it played for about 5-10mins and crashed.

    Bare in mind i had alot of dust atleast 3 years of it!
    If your computer seems to be clean and ventilated then there is nothing else i can say. As you said there is nothing wrong with your system.

    Other than that i cant help you anymore because WOW i have never played goodluck.

    Hope this helps :)
     
    Last edited: Feb 18, 2007
  5. Nourbasil

    Nourbasil Member

    Joined:
    Dec 29, 2006
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    16
    Probably your Video card
     
  6. arcturis

    arcturis Member

    Joined:
    Feb 13, 2007
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    11
    You might want to try updating your driver for the video card that you have. Your system specs seem fine in order to play it and I believe WoW's minimum requirement for a video card memory is 128MB. I have a onboard 128MB video card on my laptop and it played WoW fine. So see if updating the driver helps.
     
  7. cdxanti

    cdxanti Member

    Joined:
    Apr 13, 2007
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    11
    did you try reinstalling
     

Share This Page