1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

X-Box 360 Older iXtreme Firmware

Discussion in 'Xbox 360 - Modding & Hacking' started by joe22w, Jun 14, 2011.

  1. joe22w

    joe22w Member

    Joined:
    Feb 7, 2010
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    11
    I was wondering if there was a list of games that require the new LT firmware. I have the older firmware (the one before it), and I'm not sure whether to play newer games burned on a DVD. The game I am going to try out now is Alice Madness Returns, so could it work on a console without the new LT firmware? Or is it a waste of DVD's and time?
     
  2. joe22w

    joe22w Member

    Joined:
    Feb 7, 2010
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    11
    Could anyone please reply? Do all the newer games require LT+ ?
     

Share This Page