1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

you've got to be kidding me

Discussion in 'Sony PSP - Mod and firmware discussion' started by officerkc, Jul 29, 2007.

  1. officerkc

    officerkc Member

    Joined:
    Jul 29, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    Ok i was all like im gonna get a psp and put sweet stuff on it. i read somewhere that the only unhacked version of the firmware (at the time) was 3.51 and that it was pretty new so unless you updated you wouldnt get it. i bought a used psp from the local gamecrazy. i didnt bother to check what firmware because i figured the person before me wouldnt be a jerk or what not. ok so i check and sure nuff its 3.51 and im like WTF. so im sol because well i wanna play damn mario.

    talking to some people they said just tell sony its broken and theres a year warranty and they can send you a refurb one and it should have lower firmware so do that. ok i call sony and itll take forever to do that. i figure i have my receipt from gamecrazy ill just get another one. They say they dont have any used psps and will call if they find one. (keep in mind im telling them my psp freezes up on games)so just to see how Gamestop works i go there and ask the guy if he has any used psps. hes like yea we have 4 right now. and im like oh, do you know what firmware they are. and hes like well they are pretty high. i think one is even a 3.30 or something. i think the lowest is like 2.82, but no 1.5's. and i said yea those jerks at gamecrazy sold me a 3.51 and hes like i didnt know they even came out with that. so gamecrazy calls me back, good news we've got another used psp in. i said finally and the guy just exchanged it didnt give me a chance to check it out and F""" its another 3.51. you guys im running out of ideas!
     
  2. Ce_Yu_Pe

    Ce_Yu_Pe Regular member

    Joined:
    Jun 10, 2007
    Messages:
    595
    Likes Received:
    0
    Trophy Points:
    26
    Just get the version 3.30 psp and upgrade to 3.50 then downgrade using unpatched Lumines game.
     
  3. reloadSE

    reloadSE Regular member

    Joined:
    Apr 7, 2007
    Messages:
    184
    Likes Received:
    0
    Trophy Points:
    26
    Ebay, Amazon OR Trademe (if you kiwi or oz) (dont no much bout Amazon or ebay though)
     
  4. Greed0

    Greed0 Member

    Joined:
    Mar 16, 2007
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    16
    how much u bought the usedpsp for? man you`re lucky XD the dreaded 3.51 frmware is haunting you. i would say but a new psp (not used) or keep trying your luck with used psps
     

Share This Page