1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem A very, very weird problem with Action Replay MAX

Discussion in 'PS2' started by Dan McHumanguyPerson, Jun 12, 2017.

  1. Dan McHumanguyPerson

    Dan McHumanguyPerson Newbie

    Jun 12, 2017
    Likes Received:
    Trophy Points:
    PS2: SCPH-39001 (Fat)
    MC: nYko licensed MagicGate PS2 memory card (8MB)
    AR MAX version: v3.71 (has Max Memory, no Media Player)
    Homebrew used: FMCB v1.95 Noobie Package

    Warning: Very long post!

    After experiencing the wonders of FreeMCBoot (FMCB) and other homebrew programs, I had wanted to move my backed up saves (.max format) to my memory card through AR MAX (since I didn't trust the stability of directly converting MAX saves to .psu format through PS2 save builder or PS2 save converter, since AR MAX saves are compressed, or "crushed"). However, when I tried to open up AR Max with my flash drive and memory card inserted, the software "froze" at the primary loading screen. The loading screen would get to the point where the text at the bottom says "loading profile settings", and stay there for a while. I didn't have profile settings saved on my memory card nor my flash drive, by the way. Then the background animation would freeze, but the music and foreground loading animation (the blue/white flashing bulb under the Datel logo) would continue. I waited for a while until I realized that I was effectively "soft-locked". I turned off the PS2 by holding down the power button.

    I had read on a forum somewhere about someone that had a similar problem, and the user who had that problem stated that they could reach the AR MAX main menu by removing their memory card before launching the disc. I tried that and I was able to reach the main menu (the loading screen skipped the "loading profile settings" phase) and load Max Memory (the memory manager). Once I booted into Max Memory, I tried inserting my memory card and flash drive to attempt to transfer the saves, thinking it was a simple bug. I was wrong.

    I checked my flash drive in the "My Devices" menu and my save backups seemed to load fine. When I backed out of the "My Devices" menu, I heard the "cancel" sound effect and I suddenly had no input on the screen. I pressed every button I could press and even tried the button combo to reset the AR MAX disc, but nothing worked (all while the background animations and music played as normal). Soft-locked again.

    I had thought that FMCB was causing conflicts with AR MAX, so I booted the installer from my USB, uninstalled FMCB, and formatted the memory card just to be safe,
    moved my backups to my computer, and reformatted the flash drive to FAT32 to be safe on the flash drive side as well. Big mistake.

    I tried starting up AR MAX normally (memory card inserted only), and ended up soft-locked at the main loading screen again. I had transferred my modded System Configuration file that I used for the Independence Exploit back on my flash drive, reset the PS2, and loaded AR MAX successfully without the memory card. I entered Max Memory, inserted the memory card, and tried to "uncrush" the system configuration file to the memory card. As soon as I pressed X on the option to uncrush to the memory card, I had lost all input from the controller and nothing on screen happened (another soft-lock).

    I reset the PS2, loaded into Max Memory, and tried to open the memory card contents in the manager. Again, the software took way too long to search for a 4kb file (granted, the card was mostly empty) and I eventually decided to try to format the memory card in the My Devices menu. The screen blurred (as it should), but nothing else happened on screen (background animations and music continued), and I lost input from the controller (I knew this because I tried the reset disc button combo and sadly it didn't work).

    I was quite worried that the memory card as a whole was completely screwed, but get this: everything else still works! I loaded up several games and they were able to load and save data as they should. The PS2 browser still worked for deleting save files. I still wanted to try AR MAX again by loading it up with a memory card populated with game saves (didn't work). At this point, I've given up trying to find an answer (or a way to be able to use my AR MAX again and get FMCB back).

    My hypotheses for why this is happening:

    1. Some AR MAX file that was saving must have gotten corrupted so badly that not even reformatting the card would get rid of that data. The file would have been read by the software which would have instructed the software to load a nonexistent profile save. This would explain why the software would soft-lock at the main loading screen, but this suggests that the easy fix would be to change a setting and save it. I tried that, and the software soft-locked when I tried to save (this time it showed a progress bar to save, but it never showed any signs of progress). And that wouldn't explain the soft-locks in Max Memory.

    2. Possible AR MAX disc damage: I was wary of this possibility since the disc was in immaculate condition (and I got it three days ago) and the only disc reading problems I had was due to my PS2 not reading CDs very well in general. Not only that, but the AR MAX still worked perfectly for everything else (the actual cheating and the DVD Region X), as long as you didn't have to write/read data to/from the memory card. This can explain how the problems I'm having are specific to AR MAX and its usage, even if the damage was somehow so precise that it affected all operations regarding reading and writing data from the memory card only.

    3. The memory card is screwed, and I should buy a new one: This hypothesis states that some low-level software (such as a file system or the MagicGate encryption) may have been corrupted or that the actual hardware in the memory card is damaged (possibly deformed connections, semiconductor damage, or simply dirty contacts). This possibility wouldn't make much sense, since it would have to apply to all read and write processes, regardless of the software being used. My PS2 games and the PS2 browser can use the memory card just fine; it is only AR MAX that was having issues. Maybe a sector on the memory or a sub-partition of sorts that only AR MAX uses may have been damaged or corrupted.

    If you have any suggestions or possible insight into how I can solve this problem in any way, please let me know.

    Update: 6-12-17:
    Problem still not solved. I've messed around in the MAX Memory menu and found this: ​
    in the "My Devices" menu, the Memory Card Slot 1 icon would not darken when I removed my memory card, as if the software still thinks the card is inserted. I backed out of the "My Devices" menu and tried to re-enter it. Guess what happened? Soft-locked. As soon as I pressed X, I heard the sound effect but nothing happened and I couldn't do anything by normal means. I had also tried a trick that I read on a PCSX2 forum where the PS2 would be tricked into thinking that the memory card was un-formatted (as if you were inserting the card for the first time) and would give you the option to format it (because hopefully another reformat should help). Didn't work. But at least everywhere else my card works just like it should. Maybe if I get desperate enough to get FMCB back I might try a swap trick or something, but I really don't want to do that since I'd already spent enough money on the AR MAX and I don't want to risk damaging my PS2.
    Last edited: Jun 12, 2017
  2. scorpNZ

    scorpNZ Active member

    Mar 23, 2005
    Likes Received:
    Trophy Points:
    Consider getting an adapter & use an hdd

    ok this here is where you need to go,just copy/paste what you have already written.ffs don't spam to get your first 5 posts.read forum rules.

Share This Page