1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ASPI Helper Driver Problem

Discussion in 'Convert DVD to another format' started by adlion944, Mar 4, 2004.

  1. adlion944

    adlion944 Guest

    After many, many successful rips, I now can't get SmartRipper to work. It reports that it can't access my ASPI drive.

    This is a NEW problem that came up since I installed muthafriggin ACE Mega Codec Pak. It screwed up my system so I uninstalled ACE Mega and had to reinstall Windows XP. Tip - avoid Codec packs.

    I've tried every ASPI tip I've come across including ForceASPI, reinstall of Adaptec ASPI drivers (not sure if I did it correctly) and reinstalling Nero 5 to get their ASPI along with it.

    No dice. I get this error message when I run ASPICHK...

    LOG0143: *****************************************************************
    LOG0144: Starting ASPICHK installer on Thu Mar 04 08:46:17 2004
    ASPICHK0438: OS = Windows NT (5.01.2600)
    UPGRADE1004: c:windowssystem32wnaspi32.dll dated 09/10/1999 17:06:00, 45056 bytes.
    UPGRADE1062: c:windowssystem32wnaspi32.dll version
    UPGRADE1004: c:windowssystemwinaspi.dll dated 09/10/1999 17:06:00, 5600 bytes.
    UPGRADE1062: c:windowssystemwinaspi.dll version
    UPGRADE1004: c:windowssystem32driversaspi32.sys dated 09/10/1999 17:06:00, 25244 bytes.
    UPGRADE1062: c:windowssystem32driversaspi32.sys version
    UPGRADE1004: c:windowssystemwowpost.exe dated 09/10/1999 17:06:00, 4672 bytes.
    UPGRADE1062: c:windowssystemwowpost.exe version
    ASPICHK0582: ASPI is properly installed, but one of the helper drivers has failed to initialize (0xE3).
    ASPICHK0592: ASPI installation has problems
    LOG0218: Closing installer log on Thu Mar 04 08:46:17 2004
    LOG0219: *****************************************************************

    The sentence to note is that ASPI drivers are present but there is some third party issue... The "helper drivers won't initialize" whatever the F that means. Can't find any articles on that subject.

    BTW, I have an HP DVD+RW burner. It worked just fine before ACE Mega and my Windows XP reinstall.

    Last edited by a moderator: Mar 4, 2004
  2. ScubaPete

    ScubaPete Senior member

    Mar 13, 2003
    Likes Received:
    Trophy Points:


    I see nothing about a third party issue, I see that one of the drivers in the layer is probably corrupt - Let's send you to the Adeptec ASPI store and have you pick and install another ASPI layer -


    Let's uninstall SmartRipper and then reboot (to ensure that it gets cleared out) then reinstall SmartRipper from the web site (not your HD) after it's installed, reboot, (to allow it to settle in) then let's install your ASPI layer -= all should be clean now - give it a shot -

    When you have a moment, could you tell me why you like SmartRipper so much or are you trying to rip to MPEG to burn to a CD ?


    BTW, Welcome to the Club :D)
  3. adlion944

    adlion944 Guest

    Thanks for the help. I think the problem was that I wasn't installing the ASPI layer properly. Whatever I did fixed it.

    Though ASPIChk still is red because half the drivers seem to be .60 and the other 2 are .72

    But SmartRipper and Primo work, so I'm happy.

    I like SmartRipper because it's simple to use and very effective. Successful rip every time. It was the first program I ever used to rip my DVDs and the tutorial just gave me a comfort factor with it. I like how you can only rip the main movie and not waste time with the whole thing. Makes things quicker to get to DVD2ONE and then to Primo.

    Thanks guys.
    Last edited by a moderator: Mar 8, 2004

Share This Page