1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Azureus Help!!! Nat Error

Discussion in 'Windows - P2P software' started by PuNkLiVeS, May 25, 2005.

  1. barry6521

    barry6521 Member

    Joined:
    Nov 13, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    11
    Hi does any one know how to disable DHT in azureus
     
  2. mistycat

    mistycat Active member

    Joined:
    Nov 3, 2003
    Messages:
    3,142
    Likes Received:
    0
    Trophy Points:
    66
    I don't use Azureus, so don't know but this seems awfully involved. Anyway, have a look: Azureus tutorial for disabling DHT:

    Open options in Azureus.
    In the Connection tab make sure all of the boxes except the 2 under Networks and Peer Sources are unticked They are not required!
    Make sure "Public IP network (not anonymous) and "From a tracker" are Enabled.

    Next go to "Plugins\Tracker\Web" and DISABLE it

    Next go to "Plugins\Distributed DB" and DISABLE it

    Next go to "Plugins\Distributed Tracker and DISABLE it

    Next go to "Plugins\JPC" and DISABLE it.
    I personally don't see the point of it as all p2p data from your client will come via a proxy that your isp has to deploy. This is supposedly meant to increase performance but it would require multiple users wanting the same data from the same cache and that is even if your isp has deployed one. Untick the two boxes under the JPC to disable.

    Next go to "Tracker Client" and "Enable key passing to tracker for enhanced security"

    Next go to "Tracker\Server" and DISABLE all.

    Then go to "Sharing" and ENABLE "Private torrent - only accept peers from the tracker"
    Also UNTICK "Add hashes for other networks", I don't see why you would want it.

    *** After this restart Azureus to let the changes take effect. After these changes your client will not be broadcasting ET peers to others and you won't be wasting your upload to others. These changes will not stop you connecting to ET or other private trackers, nor will it stop you connecting to public trackers.
     
  3. Sessel51

    Sessel51 Member

    Joined:
    Feb 22, 2007
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    11
    I just started using Azureus today and am having quite a few problems with it. I have use bit torrent many times in the past but have not downloaded anything in a long time. I noticed the blazing 200 B/s connection speed and the nice firewall'd light so I thought something was wrong. The NAT/ Firewall Test keep telling me it failed to connect to port. I checked and found my ports were not forwarded. I forwarded them and then the Firewall Test would time out and fail to connect. I checked the AZ wiki and asked around the IRC but nothing that anyone has said has helped. I've tried just about every configuration suggested ( enabled UPnp, disabled it, enabled encryption, etc.) but nothing changed. Windows firewall is off and I have no other firewalls running (checked with Iknow and Filemon.) My ISP is AT&T SBC and I am using 2wire router/modem(2701HG-B). Its not just Azureus that is getting this problem either, I am having the same problem with Bitcomet and Blizzard's patch downloader for WOW (2 hours to download a 2mb patch...). Any help anyone can give me would be much appreciated.
     
    Last edited: Feb 22, 2007
  4. mistycat

    mistycat Active member

    Joined:
    Nov 3, 2003
    Messages:
    3,142
    Likes Received:
    0
    Trophy Points:
    66
    Try a port over 50,000, if you haven't and check at ipconfig/all that the ip address you forwarded to is correct or set it to static.. Also, if that router/modem is wireless, try connecting it directly if you can.
     
  5. jimfitter

    jimfitter Member

    Joined:
    Jan 5, 2007
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    11
    Without a firewall, look to the problem in your router.

    ATT/SBC user. Advertised download speed at 1.5 -3.0 mb.

    On a well seeded torrent I stay around 200-280+ kB/s.

    Enable encryption. Use autospeed. Set down to up ratio to 10:1.

    Follow recommended settings in Azureus guide, and be patient. It took time and tweaking to achieve those speeds.
     
  6. barry6521

    barry6521 Member

    Joined:
    Nov 13, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    11
    error message keeps popping up in the right hand bottom of azureus it says "too many successive failures occurred on port 56578,UDP-processing abandoned. please check firewall settings for this port to ensure that it is enabled for receiving connections" both the Ratio and NAT are showing green and when i do a port test it comes back as OK is there any one who may be able to shed some light on what the problem may be Cheers
     
  7. lego001

    lego001 Member

    Joined:
    Feb 14, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    What section of options is "enable encryption" at?
     
  8. mistycat

    mistycat Active member

    Joined:
    Nov 3, 2003
    Messages:
    3,142
    Likes Received:
    0
    Trophy Points:
    66
  9. jimfitter

    jimfitter Member

    Joined:
    Jan 5, 2007
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    11
    ^Tools>Options>Mode. Set to advanced.

    Tools>Options>Connection>Transport Encryption.

    Check: Require encrypted transport.

    Set level to RC4.

    Check: Allow non-encrypted...

    Check: Allow non-encrypted incoming conn.

    Do not check the last one.

    Finished.
     
  10. ventdrags

    ventdrags Guest

    Hi, I have a NAT problem with Azereus and I've followed every direction that is given at the wiki. I switched off my firewall, created a static IP and port forward through my router (49344). I did a NAT/Firewall Test and the results showed OK. I went to check further at CanYouSeeMe.org and the results showed that my port (49344) is not blocked. Despite all that, I still have the NAT button showing red and labeled 'firewalled' and I have the yellow smiley face beside my download all the time. My torrent download speeds don't go beyond 3 kb/s although i have a broadband connection.

    FYI, my computer OS is Windows XP with SP2 and my ISP is not one of those listed that causes problems with bittorent.

    Anyone can help out with the problem?
     
  11. droppy88

    droppy88 Member

    Joined:
    Mar 6, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    I don't know what to do with azureus anymore. I use port 50682 because after testing it, it said it's ok. I tryed forwarding it through windows firewall but my speed decreases. Disabled all firewalls, the same thing. Speed is always below 25 kb.
    I talked to my isp and he said he doesn't even know what azureus means. The guy said to enable windows sp2 firewall 'cause it's gonna work.. but it obviously didn't. He increased my band but that didn'ty helped either. I don't know what to try else. Pls help!
    I have a 100.0 Mbps LAN connection, no firewall and symantec antivirus under xp with sp2.
     
  12. mistycat

    mistycat Active member

    Joined:
    Nov 3, 2003
    Messages:
    3,142
    Likes Received:
    0
    Trophy Points:
    66
    A speed below 25 kbps doesn't necessarily mean anything, never going above 25 kbps does. Enable Protocol Encryption: http://forums.afterdawn.com/thread_view.cfm/395674 and disable UPnP: http://www.azureuswiki.com/index.php/UPnP Window's Firewall should be fine, it's all I've used for years and no problem here, just ensure Azureus is checked as an exception. Your ISP not knowing what Azureus is doesn't mean they aren't blocking torrents, who is it or do you see it here: http://www.azureuswiki.com/index.php/Bad_ISPs
     
  13. janrocks

    janrocks Guest

    Most seem to block ports 68XX to 69XX as a matter of course these days. A lot of membership trackers also disallow connection on those ports.. go high.
     
  14. droppy88

    droppy88 Member

    Joined:
    Mar 6, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    it lookslike it's working.. 10xs a lot
     
  15. jimfitter

    jimfitter Member

    Joined:
    Jan 5, 2007
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    11
    Did you enable your firewall? For f*ck sake, don't keep it disabled just for the sake of a faster download.

    If your firewall is still giving you porting problems, try Comodo. It's free, and the customization controls are pretty straightforward. I use it with no problems.

    Always enable your firewall!
     
  16. Amtiskaw

    Amtiskaw Member

    Joined:
    Mar 26, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    Just wondering if ANYONE can help me with my NAT problem. The NAT status has been showing firewalled constantly for the last couple of weeks even though i previously had no problems. i'm on an intel imac connected wirelessly to a 3com 3crwe754g72-a router, my isp is pipex. i've logged in to my router and checked the forwarded ports, i have port 54321 open for both tcp and udp connections, as it has always been for azureus which is why i'm at a loss as to why it's suddenly become firewalled! i've tried loads of different things, i've followed everything the azureus wiki has to offer on it's NAT help page. i've enabled and disabled upnp on both my router and the azureus client, neither way works. i've tried telling the client to use a different port and opened this new port on my router....this doesn't work either. i've run a port scan on my computer and it shows the appropiate ports as open! i've even disabled the router firewall all together but still azureus says it's firewalled! i'm just at a complete loss as to what the fusk is wrong! why should a previously fine set up suddenly start showing firewalled? the only possible thing i can think of is that i recently encrypted my wireless connection but why should this have any effect on open ports?? just in case it was something to do with this i also disabled the encryption but still azureus says firewalled. it's really REALLY pissing me off now! I considered trying another client but i don't think it's the client that's at fault as i'm also having problems with soulseek at the moment, again i've changed NO settings on my router to do with soulseek, all the correct ports are still open etc yet the number of ppl uploading from me has fallen dramatically and people who used to be able to browse me suddenly can't. could this have anything to do with my isp (pipex), have they suddenly blocked or limited p2p traffic in the last couple of weeks? please help me before i smash my computer.
     
  17. stevegg55

    stevegg55 Member

    Joined:
    Mar 26, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    I'm having exactly same probs as Amtiskaw, AND I'm with PIPEX.
    Maybe theres a connection.
    Any others out there having probs with pipex?
     
  18. mistycat

    mistycat Active member

    Joined:
    Nov 3, 2003
    Messages:
    3,142
    Likes Received:
    0
    Trophy Points:
    66
    As far as I know, Pipex throttles all p2p and Google has numerous threads regarding this. You could try downloading between 12:00 A.M. - 6:00 A.M.
     
    Last edited: Mar 26, 2007
  19. jimfitter

    jimfitter Member

    Joined:
    Jan 5, 2007
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    11
    @Amtiskaw: this might seem a dumb question to you, but it's a solution that's sometimes overlooked:

    Have you tried closing out of Azereus, opening your task manager to make sure the Azureus.exe application is not running, rebooting your router and modem, and then restarting Azureus.

    I've had an NAT wall on occasion, and that procedure has always worked for me.

    Look first to your router. It sounds like that is where your problem lies.

     
  20. Amtiskaw

    Amtiskaw Member

    Joined:
    Mar 26, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    I think i found the out what was wrong. I started having NAT problems about the same time i downloaded the latest apple osx update for my imac. it seems osx has an inbuilt firewall like xp and i wonder if the latest update affected it in someway. anyway, i downloaded a program called 'Flying Butress' that lets you tinker with the apple firewall. at first i just let it let everything through then turned of bits one by one. my NAT problem has now disappeared. If you're on osx and having NAT problems it can't hurt to give it a try, the flying butress program was free 8)
     

Share This Page