1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Bitorrent Displays "unable to forward port via UPnP"

Discussion in 'Windows - P2P software' started by sakka44, Jul 26, 2006.

  1. sakka44

    sakka44 Member

    Joined:
    May 14, 2005
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    16
    Bitorrent was working up and fine until I installed Norton Antivirus 2006. After this was installed and tried to download a number of torrents, they each said "Couldn't listen - unable to forward port via UPnP" I have a linksys router, and followed the instructions on forwarding ports through my router. After doing this, nothing changed so I went into Norton's worm protection, and told it to "Permit All" from the bitorrent .exe file. Still nothing has changed! Does anybody know what I should do?
     
  2. sakka44

    sakka44 Member

    Joined:
    May 14, 2005
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    16
    no answers?
     
  3. trysberg

    trysberg Member

    Joined:
    Aug 13, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    I have the same problem. Help would be appreciated!!!
     
  4. TomMelee

    TomMelee Regular member

    Joined:
    Jun 13, 2004
    Messages:
    770
    Likes Received:
    0
    Trophy Points:
    26
    Couple things here.

    1, stop using UPnP. UPnP's function is to dynamically create forwarding rules when programs ask for them. There is NO REASON to forward ports if you've enabled UPnP in your client. I would disable UPnP, and then set up your forwarding rule. Symantec/Norton assume that you are an idiot, and unable to make your own rules, so they have master rules you can't do anythign about. It's idiot proof, in other words.

    2. Norton Internet Security is GREAT for people who are NOT computer savvy, and who do not download. It is HORRIBLE for power users. I think what is happening is that NIS (norton) is seeing the UPnP request from the program, and because the UPnP is done @ kernel level, it thinks it's unfriendly and blocks it.

    3. 2 fixes. 1, turn of UPnP in your client and just use your forwarding rule instead. Norton SHOULD allow it, assuming you've permitted "All connections" for the correct application. 2. Disable NIS while downloading, and/or uninstall it all together. If it works when NIS is disabled, you know it's NIS, and, well, it is. If you really feel like you need a software firewall, I recommend Kaspersky or BlackICE.

    Good luck. Post back if you have any more questions.
     
  5. trysberg

    trysberg Member

    Joined:
    Aug 13, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    Thanks! Excuse my ignorance. I´m not an computerexpert so how do i turn of UPnP?

    I have Norman Antivirus, not Norton. Maybe it doesn´t matter? I don´t know how to disable Norman.

    The strange thing is that i can somtimes download(slow) and mostly not? It´s like the computer is "thinking" up to 8-10 seconds before i get the errormessage.
     
  6. TomMelee

    TomMelee Regular member

    Joined:
    Jun 13, 2004
    Messages:
    770
    Likes Received:
    0
    Trophy Points:
    26
    You "uncheck" the "enable UPnP" box in your torrent client.

    And normally, firewalls can be disabled by right clicking on the taskbar icon.

    Good luck.
     
  7. trysberg

    trysberg Member

    Joined:
    Aug 13, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    It really helped. Thank you very much. I´m very grateful!
     
  8. TomMelee

    TomMelee Regular member

    Joined:
    Jun 13, 2004
    Messages:
    770
    Likes Received:
    0
    Trophy Points:
    26
    Horray for me! Lol, plus 1 for the Melee. Glad you got it working.
     

Share This Page