1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I need help...

Discussion in 'Sony PSP - Mod and firmware discussion' started by Dumbolme, Apr 19, 2007.

  1. Dumbolme

    Dumbolme Guest

    I had firmware 2.71 on my PSP (and my PSP is not the TA082 version). I installed DevHook to my PSP and downgraded to a 1.50. That was successfuly, then I installed the 330oe_c and flashed my PSP. Got an error on creating files when flashing it at the step when it says Press X to continue after I've copied the DAX file to the 330oeflasher file (instructions taken from http://forums.qj.net/f-psp-firmware...tion-guide-faq-and-support-thread-84905.html) ... Now my PSP is bricked I can't get it on, the screen is black, I tried the recovery method by pressing "R" but still no luck. Please help!!! I don't have a lot of money to spend on buying a new PSP.. Thank you to any helper!!!
  2. fultonla

    fultonla Guest

    I'm sorry to say it is completely bricked.

    the only way of fixing it is to replace the motherboard or get a mod chip.

    the reason you bricked is because what you did was not downgrade to 1.5 but emulate it so you did not truly downgrade.

Share This Page