1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

loaders dont work on 1.5 psps

Discussion in 'Sony PSP - Homebrew software' started by prodigy47, Apr 5, 2007.

  1. prodigy47

    prodigy47 Guest

    i have a psp 1.5 and downloaded games from internet. i tried loading need for speed underground ,it did not work. i tried burnout legends it did not work , even tried wipeout pure still nothing loads . all thes games are in iso format and i tried all loaders like devhook 0.46 ,devhook 0.22 then umd emulator v8.c ,fastloader v.8 i dont get it where i m goin wrong . da problem is that all these games show up on da system menu of psp but when presses x to load a black screen appears i would appreciate it if someone can help me out or figure out where i m makin a mistake plz reply me or u can even email me at fort_minor47@yahoo.co.in thanx
  2. MidnightJ

    MidnightJ Guest

    Just upgrade to 3.03 OE-C. And the reason there not working is because your not emulating firmware. 3.03 OE-C is a lot better, 1.5 is kind of pointless to have now. Since custom firmware are 1.50 + a ton of other awesome stuff.
  3. prodigy47

    prodigy47 Guest

  4. prodigy47

    prodigy47 Guest

    thanx for helpin me but is it that devhook 0.46 cant load any game since u r tellin me to get an upgrade to 3.03 oec i read alot about this devhook it should at least play one game alight no problem but can u tell me in details how do i upgrade it plz :)
  5. chanman1

    chanman1 Regular member

    Feb 6, 2006
    Likes Received:
    Trophy Points:

Share This Page