1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need assistance in dumping MS28 with mtkflash

Discussion in 'Xbox 360 - Modding & Hacking' started by ha9981, Jan 23, 2007.

  1. ha9981

    ha9981 Regular member

    Nov 7, 2006
    Likes Received:
    Trophy Points:
    i used xtreme boot maker the newest one and was able to make a bootable disk with which i booted in to dos and tried to flash my ms28 using a via 6421a chipset card. The drive is detected and i tried the ten second method after selecting it except it gives me the following error:

    the error i get is:
    port a000, primary/slave a0

    i heard that the problem is the u need cd/dvd with mediatek chipset. is that it? what could the problem be?

    checked my mtkflash in hex editor and it is all good.
    any tips?
  2. PS2Menace

    PS2Menace Regular member

    May 1, 2006
    Likes Received:
    Trophy Points:
    Here's the easy way to flash/dump the m28
    Make sure the SATA cable is connected to the PC on the Via 6241a on the primary SATA.
    Turn on the 360
    turn on pc
    get to dos and type mtkflash r /m /sata orig.bin
    Hit enter
    turn off 360
    select 3 (xtreme primary)
    wait 15 seconds
    turn on 360

    should start dumping.

    After you dump original firmware go to the xtreme 5.2 folder and copy orig.bin there
    run the make xtreme firmware command
    take the x52x.bin file and copy it back to the boot disc

    do the exact same method as dumping but use this command instead
    mtkflash w /m /sata x52x.bin

Share This Page