1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Not your average Disc Read Error... help.

Discussion in 'PS2 - Software boot discussion' started by Budnick, Jun 24, 2004.

  1. Budnick

    Budnick Guest

    Once upon a time, my system got the Disc Read Error, so I searched around here and found that the problem was more than likely a dirty lens. So I opened the PS2 up, cleaned the lens and placed the cover back on... all very carefully. Of course it worked like a charm. Since then, I clean the lens about once every three months, when games start to freeze or booting up takes a whole minute.

    The last time I did this, I pinched the ribbon cable. Not all the way, just one fraction of an inch. It was still enough to kill the Eject button though, and since that day I've had to open the PS2, remove the DVD drive cover and change discs. Sure, it's a pain in the ass, but I managed.

    Then. tonight... the cover is off, I walk over to my shelf to get another game and BAM, hear the top cover hit the ground, jerking the ribbon cable completely out. I thought "Hey, no biggie, I can put it back in". So I go into the PS2, see the little slot where it came out of, and try to put it back in. But it won't stay. Turns out the little brown snap-lock popped off, so to get that back on, I have to remove the whole DVD drive, disconnecting three ribbon cables, one large brown one, one large white one and one small brown one, along with four other wires. All of them are simple enough to put back together it looks like, so I proceed with what I came to do... fix the power ribbon cable.

    Once I put everything back together, I flick the switch and presto, red light! Job well done, until I reach the "Browser" screen and notice the formation of eight glowing balls isn't moving. I knew instantly something was wrong and sure enough, after two minutes of waiting, "Disc Read Error".

    So can anyone point me in the right direction about which cable/ribbon to focus on?

    The DVD drive spins, grinds (normally) and I pushed the laser back and after running the system for a minute, opened it back up and the laser had moved forward... so I don't think that's the problem, plus the laser is getting power.

    I'm guessing it's the white ribbon... everything else is firmly in place, while I can't get a good grip on that one to plug it in. I need someone to confirm this before I go digging in, though.

    This happens two days after I finally order a modchip, too. Which means I can't rush out and buy a brand new V9 or V10 system. Sucks.

    Alright, thanks...
  2. devilhunt

    devilhunt Active member

    Aug 30, 2003
    Likes Received:
    Trophy Points:
    check that the clock etc is set as this will stop the lights/balls/electrons from moving
  3. Budnick

    Budnick Guest

    I set the time and it fixed the electron problem.

    Think I could have messed up the voltage when I was taking everything apart? That's the only thing I haven't tried, and now that I know the electron problem isn't anything major, like a loose cable, it could be that.

Share This Page