1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PS2 Mod Chipped Wont Play DVD-R Backups

Discussion in 'PS2 - DVD backup discussion' started by simonpvs, Oct 27, 2004.

  1. simonpvs

    simonpvs Member

    Oct 27, 2004
    Likes Received:
    Trophy Points:
    I've got a PS2 which has been modchipped a few years back (uses DVD Region X to play CDR Backups).

    I haven't been able to play DVD-R backups.

    I've followed all the tutorials etc, but it just wont work. I've tried multiple apps to create and burn an image file, however the PS2 doesn't like it. I just get the red screen at boot.

    I've tried using the Region X disc to no avail.....

    I know my PS2 will read the media as I've backed up my DVD Movies and they play fine....I use Ridata DVD-R's.

    Same thing happens when I burn to CDR, however this will start to load (for eg Harry Potter 2), but it freezes after it starts.

    Do I need to buy a swap disc for the DVD-R's?

    Or should I be able to play them already?

    Also, why dont my CDR backups work when I burn them?

    Any help appreciated.



  2. Legras

    Legras Guest

    i have a ps2 mod chip and it doesnt boot up dvd rs when i hold down the rest button for 10 seconds and let go and the tray is suppose to open by its self but it doesnt for some reason with using game shark. i have a ps2 neo 2.2 the first step up for ps2 boot games and its a old ass chip. i find out later on that my friends ps2 plays dvd rs and he has the same set up i just had bad luck with my ps2

Share This Page