1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PS2 Read Error

Discussion in 'PS2 - DVD backup discussion' started by SabbyTa, Apr 23, 2005.

  1. SabbyTa

    SabbyTa Guest

    Have a PS2 V7 with a Messiah2 Pro chip installed. Seems like everything I download recently ie. Midnight Club 3, MX vs ATX unleashed will not work. Once the files are downloaded and unzipped, I use Ridek G04 discs and burn at 2x. I've tried burning in Nero 6 using the UDF/ISO setting or DVD Decrypter. I always get a perfect burn with no errors. My PS2 will not read the discs, I get the memory card/disc screen. If I put other discs that have been burned, the machine reads them fine. Any suggestions would be appreciated.
  2. p4_tt

    p4_tt Active member

    Feb 3, 2004
    Likes Received:
    Trophy Points:
    I dont know too much about the Messiah2 Pro chip but will try to help, Try using alcohol 120% to burn your games, Can you download updates for your chips bios? I have both games your talkng about, i can play them fine with swap magic, also when you put them in your ps2 do you get the "disc read error"?

    Hope this helps.
    Last edited: Apr 23, 2005
  3. SabbyTa

    SabbyTa Guest

    I'm not sure if there's any updates on this chip, I pop the disc in and the screen goes to black. After a minute or so the memory card and a picture of a disc pop up. If I click on the disc the screeen goes black again and returns to the previous screen.
  4. john1888

    john1888 Guest

    use alcohol 120 to burn ur disc as an image file at 2x speed and try using a dvd-rw, i to had the same problem and started using dvd-rw and have'nt had a problem yet, or u could try standing ur ps2 verticly.

    ps: this problem is caused by ur ps2 laser not the way ur burnig ur games if u want to sort it properly buy a new laser or go for the cheaper option of using dvd-rw as i did

    hope this helps you
  5. SabbyTa

    SabbyTa Guest

    I used Alcohol 120 to burn and it worked like a charm. I wonder why it works with this and not the two other programs. Thanks!
  6. john1888

    john1888 Guest

    glad to help........anymore problems with anything just let me kno

Share This Page