1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PS2 Reset Button not working but eject button does

Discussion in 'PS2 - Hardware boot discussion' started by Josepine, Dec 1, 2020.

Thread Status:
Not open for further replies.
  1. Josepine

    Josepine Newbie

    Joined:
    Dec 1, 2020
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hello Everyone
    Nice to meet you.

    I want to share a case that i currently working on and ask some question about it.

    So 2 days ago i got a faulty PS2 which didn't have any display issue. After i checking it there's a few solder ball beneath IC GS that didn't contact with the board so i tried giving it a light pressure which is working (there's a display on the tv although the screen does cracked) so i started reworking the IC GS.

    Here's the interesting part, so when i tried again, the reset button didn't want to switch to green light, but if i press the eject button the red light would switch to green, i got blinking blue on eject button, if i hold the reset button it will go back to red light again but it won't switch from red light to green light, and the worse part is i got no display even if i give a pressure to the IC GS. I already check the ribbon cable and it work fine, no missing component, remove the mod chip, and normal voltage input on IC CY2212 and i even replace with the new one for this part.

    Anybody could help me about this case?.

    Thanks in advance
     
Thread Status:
Not open for further replies.

Share This Page