1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PSP motherboarb compatibility guide(Full)

Discussion in 'Sony PSP - Mod and firmware discussion' started by legend999, Jul 21, 2006.

  1. 613XXXL

    613XXXL Member

    Joined:
    Dec 31, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    11
    I bought one last week without reading all these posts first and I got a TA-082 with 2.50 on it. I upgraded to 2.71 firmware and I was able to use devhook 0.46 and 0.51 to play any ISO's I've found and 0.46 can load 1.50 firmware to load homebrew (with some limitations I think, I haven't tried this yet). Today I noticed The Sony Store had the value pack on sale for $199 (CDN) so I returned the one I bought last week and grabbed one. Lucked out, it is not a TA-082 and is running 2.01.

    So short answer... it is possible to get a non TA-082 from stores and even if you do you can still play ISO's if it's 2.71 or lower firmware.

    Hope this info is correct... I've only been at this for less than a week.
     
  2. BobFixIt

    BobFixIt Member

    Joined:
    Dec 8, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    Well i went out today to Costco, to see if they had the psp for sale, and they did so i got one, the entertainment pack, and mine came with ta-82 mobo and firmware version 2.71, im installing devhook and hend now...
     
  3. Kalikeiro

    Kalikeiro Guest

    I bought a PSP that has a mobo TA-082 and fw 2.71,(sorry for asking this and using this thread), but after searching in several foruns i'm still confused how to run ISO's on a PSP.
    Everyone is telling that this mobo can't run fw 1.5 but if you got fw 2.71 that's not a problem, that's my first question, so if it's ok to have the fw 2.71 i is everyone that have a similar PSP talk in using fw 1.5. Second question, since some of the new games WWE,MGS need update firmware what is the best way to start?
    Again i'm sorry for asking this newbie question, and sorry for my incorrect english.
     
  4. bishop222

    bishop222 Member

    Joined:
    Dec 8, 2006
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    16
    613xxxl,
    thanks a ton bro. I figure I can easily take it back to that retail monster with the no-fuss return policy if I get one that can't be downgraded. So funny that the Sony store didn't clear their shelves of hackable units. Knobs. You think that would have been their first move.

    Thanks for the costco tip Bob. Easy to read those boxes and sift through them looking for good numbers.

    Awesome help all. Cheers. Buying today.

     
  5. bishop222

    bishop222 Member

    Joined:
    Dec 8, 2006
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    16
    Hey,
    Last Q.: Assuming I get one with downgradable firmware and can run devhook well. . . .can I DL virtually any games that are shared and run them? (asside from shitty rips and obviously defective files?) Should I be looking for certain files?

    and I am buying a 4 gig card today (130$-cheap). . does the read/write speed make much difference guys?

    Thanks in advance.
     
  6. BobFixIt

    BobFixIt Member

    Joined:
    Dec 8, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    to: Kalikeiro

    Ya you can not downgrade a ta-82 mobo below fw 2.5, if you do you will brick your psp. But now there is really not much of a reason you would want to downgrade even if you have 2.71 thanks to dark_alex everyone can run homebrew on the 2.71 just follow this guide: http://forums.afterdawn.com/thread_view.cfm/399310


    as far as the games which require the new firmware versions, if you take the release of fw 3.01 i think that same day or the next day we had a new hevhook which would emulate the new fw.
     
  7. trellaine

    trellaine Regular member

    Joined:
    Nov 22, 2005
    Messages:
    107
    Likes Received:
    0
    Trophy Points:
    26
    Hmmm ok, I bricked my PSP last night for anyone that doesn't already know. Not sure why I am telling everyone but.......

    what it the best suggestion in purchasing a new PSP if I went out today?

    It seems even the newer versions will play my backups?

    Suggestion?

    Will any PSP with letters A-I allow me to play my backups?

    Thanks

    Or can I mod my bricked PSP and if so where can I get this done?
     
  8. evolve123

    evolve123 Regular member

    Joined:
    Jul 4, 2006
    Messages:
    238
    Likes Received:
    0
    Trophy Points:
    26
    HEY MAN WTF....i wrote this guide and you just copied it. I should deserve some credits... :(
     
  9. bishop222

    bishop222 Member

    Joined:
    Dec 8, 2006
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    16
    ok, why the hell am I so confused about this stuff? I have read all weekend! I bought the PSP today . . .ta-082 mobo. . .waiting to see which version of FW (charging). . . 613xxxl above says he d-graded his ta-082 . . .psp-hacks guides say no ta-082 can be downgraded? I'm not a retard. . . .why am I so confused. Is the stuff I read from psp-hacks old or something? If I have 2.71 or lower I should be ok right?
     
  10. eternalis

    eternalis Regular member

    Joined:
    Jan 5, 2005
    Messages:
    2,924
    Likes Received:
    0
    Trophy Points:
    46
    The reports of ta-082s being successfully downgraded are basically rare incidents. I wouldn't recommend trying it, as it is highly likely that you'll brick your PSP. Yes anything below firmware 2.71 is good as you can play homebrew and ISOs on firmware 2.71 even if it does have a TA-082 motherboard.
     
  11. legend999

    legend999 Regular member

    Joined:
    Jun 30, 2006
    Messages:
    696
    Likes Received:
    0
    Trophy Points:
    26
    Looks like you got the haunted mobo.
     
  12. wipegr

    wipegr Member

    Joined:
    Dec 18, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    hi to all,

    i am new here at the forum and searching for details about playing backup games to psp found this great site!!!!

    Ok now my questions...
    i read all the threat here and wondering what is the best EU version of psp to buy and downgrade without any errors bricks....

    A,B,C,D,E,F,I ???????

    thnx
     
  13. legend999

    legend999 Regular member

    Joined:
    Jun 30, 2006
    Messages:
    696
    Likes Received:
    0
    Trophy Points:
    26
    The chances of getting the first onesare like 0.1%.Maybe with luck you can get a 2.71 PSP(J).
     
  14. trellaine

    trellaine Regular member

    Joined:
    Nov 22, 2005
    Messages:
    107
    Likes Received:
    0
    Trophy Points:
    26
    Brand new sealed C. I guess I was lucky? Bought at the Sony Store as well. I was shocked.
     
  15. wipegr

    wipegr Member

    Joined:
    Dec 18, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    [​IMG]

    ok with the letter but with the fw version where i can see it before bying it and second i must buy and the GTA to work the FW or this is a test to see if it works?
     
  16. maishiina

    maishiina Member

    Joined:
    Dec 19, 2006
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    11
    Hi,
    Mfr. Part Number of the entertainment pack you bought is: 98509?
    Did it really get with ta-82 mobo and firmware version 2.71?
    I want to buy the same one too!How much did you pay for it?
     
  17. wipegr

    wipegr Member

    Joined:
    Dec 18, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    i check stores now they have version K what about this version of psp?
     
  18. dukeidude

    dukeidude Regular member

    Joined:
    Nov 18, 2006
    Messages:
    264
    Likes Received:
    0
    Trophy Points:
    26
    its 2.71. i just got one yesterday. can someone tell me how to downgrade a TA-082 to be able to play ISO's and such? thanks for any help. if someone could help me, just pm me or reply. thks again
     
  19. desmdlow

    desmdlow Member

    Joined:
    Jul 16, 2005
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    Just to confirm, Does it means that if my PSP is of version lower than 2.71 and motherboard is not TA-082 then it can be downgraded and i can run ISO games?
    Must i need GTA UMD?
     
  20. dukeidude

    dukeidude Regular member

    Joined:
    Nov 18, 2006
    Messages:
    264
    Likes Received:
    0
    Trophy Points:
    26
    yeah. you can downgrade and play isos
     

Share This Page