1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Rage 2 Yellow Line Direction Graphics Glitch! Quad Q9500 CPU & GeForce 1070.

Discussion in 'Windows - Games' started by retroborg, Mar 29, 2020.

  1. retroborg

    retroborg Regular member

    Joined:
    Jan 3, 2006
    Messages:
    143
    Likes Received:
    0
    Trophy Points:
    26
    Good day

    My PC Specs:

    Intel Core 2 Quad Q9500 @2.83GHZ
    MSI GeForce 1070 8GB Gaming X
    8GB Ram
    256GB Samsung SSD 850 PRO
    Win 7 PRO 64BIT
    Nvidia Drivers 441.87 English

    My problem:

    I installed and run Rage 2 and used the following Core 2 Quad CPU patch "RAGE2_dbg.zip" in order to make it work on my PC since my CPU does not support the SSE4.2 instructions needed by the game. (It needs an Core i5 CPU at minimum)

    https://github.com/unknownproject/Rage2
    View: https://www.youtube.com/watch?v=AfH6bFRKPVU


    The game runs fine @60FPS on Ultra settings, but I encountered the following glitch, whenever I press the directional arrows on my keyboard or with an XBOX joypad, a yellow line appears every time across the screen pointing the way I press and move!

    https://postimg.cc/gallery/1tmBbqN

    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]

    I have reset everything to their defaults and tried the game from lowest to highest graphics settings, but the problem persists.

    Other games like Doom Eternal seem to play just fine with no issues using a similar Core 2 Quad CPU patch.

    So any ideas on how to fix this problem?!

    Thanks in advance
     
  2. retroborg

    retroborg Regular member

    Joined:
    Jan 3, 2006
    Messages:
    143
    Likes Received:
    0
    Trophy Points:
    26
    So, it turns out it was the patch itself that was the cause of the problem after all.

    I followed the instructions as described here and everything seems to be working fine now...

    https://www.pcgamingwiki.com/wiki/RAGE_2#Game_crashes_on_Core_2_Quad

    That other pre-patched executable seems to be running on debug mode which is why it's showing the direction I move and press to with a yellow line. I have no idea how and if it's possible to disable debug mode via command prompt?...

    https://github.com/unknownproject/Rage2/blob/master/RAGE2_dbg.zip

    Anyway, I'm happy, glad and satisfied that my old rig from 2007 can still play Rage 2 & Doom Eternal at Ultra Graphics settings @60FPS without having to play loads of $$$ on new hardware just for 2 games which would lose more than 50% of its value within 5-6 months! :)

    Especially considering that Doom Eternal hasn't been living up to the hype for me so far, game-play isn't that great, all those spider-man stunts are quite irritating, the story-line is a mess and the difficulty is very unbalanced, nowhere near as enjoyable as Doom 2016 was.
    The linear level layout and storytelling reminds me of Unreal 2 from 2003 really.

    Rage 2 is great so far though! I love the massive open world and the tone of exploration and secrets. It's what Rage 1 should have been like in 2011.
     

Share This Page