1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Samsung drive - MTKFLASH/VIA 6421 Flash Error Question

Discussion in 'Xbox 360 - Modding & Hacking' started by redrob2, Jul 12, 2007.

  1. redrob2

    redrob2 Member

    May 18, 2007
    Likes Received:
    Trophy Points:
    Sorry for the long post but I am trying to be as detailed as possible. I tried flashing my Samsung with iXtreme 1.2b yesterday using a recommended VIA 6421 SATA controller board from Newegg. I used iPrep and MTKFLSH to extract the original firmware. That went fine. I tried flashing with 1.2b and it got to 59% in the 4th bank and froze. I booted up the Xbox and it acted ok but I was worried that it wasn't right so I tried flashing back to the original firmware using the bad-flash method. This worked as well and I booted up my Xbox fine with the original firmware in place again. I then tried to flash it with the iXtreme 1.2b and this is where my problems started. I am now getting a different error every time I flash (note: I have tried booting with a floppy, CD, and USB thumb drive and get the same issue with each one). Sometimes it will say updating and get to somewhere between 1% and 6% and stall at a different number each time. Other times it will just spit out fail 1, fail 2 ... and so on. Other times I will get the fail%www error. I've tried reading up on this but I haven't seen anyone who has different error messages show up ... soooo ...

    ... with that being said I have 2 questions.

    1) Is my drive really dead or is there still some life in it since it is still being picked up by the SATA controller?

    2) I am trying to use the bad-flash method as documented. I have heard simply turn it off for 10 seconds then turn it back on. I've tried 8-13 seconds as recommended and still the same results each time. Now the problem I'm hearing now is that when I turn off the Xbox the DVD is still spinning for like 4-5 seconds and I can't even turn it back on in that time. Its almost like the system isn't off yet even though there are no lights on. Should I start counting AFTER the drive stops spinning? I've also heard I'm supposed to wait 4-5 seconds to start the flashing after its been turned on until the whole green ring is lit. Is this true?

    Everyone, thanks for your help ahead of time. I do really appreciate it.

  2. lilg_06

    lilg_06 Regular member

    Aug 5, 2006
    Likes Received:
    Trophy Points:
    If your drive is still being picked up by mtkflash, then it should not be a problem, first thing is you might need to diable RAID in your computers bios, as this has been the problem for some people, I am not sure of how to do this, I flash my 360 with the normal settings, and my comps BIOS does not have any RAID options.
    When you turn your 360 off, the reason the fans and everything are still running apart from the lights for a few seconds is because the firmware on the drive is screwed, until you succesfully flash back the original firmware or hacked firmware it will continure to do this.
    You need to start counting once the xbox 360 is fully off, you can make sure that its fully of by having a look at the light on the power supply, it should be orange when the box is off.

    I would recommend you make your bootable floppy or usb drive using Xtreme Bootmaker, as this patches mtkflash to work with a VIA 6421 chipset, works fine for me.

Share This Page