1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Streaming DVD's to 360 Guide - 4 Steps Full DVD Quality!

Discussion in 'Xbox 360 - Modding & Hacking' started by sthrncali, Jan 2, 2008.

  1. mactavish

    mactavish Member

    Joined:
    Jun 17, 2008
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    16
    Last edited: Jun 18, 2008
  2. duh

    duh Member

    Joined:
    Dec 12, 2002
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    11
    mac, I am running the program and it came to, (testing compressability)and it has been there for about 8 hrs, do you know how I recognize what other codec's or codec pac's might be running, I'm going to try that download tommorrow, thanks
     
  3. mactavish

    mactavish Member

    Joined:
    Jun 17, 2008
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    16
    don't use codec packs, uninstall all codec packs and codecs before you install autogk because it will install its own codec. Install normally, don't change any thing during install. On my laptop(1.83ghz core duo) it only takes 2-3 hours for one conversion.

    The link tells you to install k-lite mega pack but don't do it, better to install autogk without any codecs or packs installed on your computer.

    Oh an one more thing, the first time you convert, a window will pop up (this happened to me), I think it is an intro screen to vitrualdubmod, just press ok on it or else it will pause your conversion.
     
    Last edited: Jun 19, 2008
  4. algtz1

    algtz1 Regular member

    Joined:
    Aug 28, 2006
    Messages:
    288
    Likes Received:
    0
    Trophy Points:
    26
    Hey mac, thanks for all the great guides and help. My question is for DVDs with episodes. I want to convert my Curb Your Enthusiasm DVD which contains about 6 episodes per DVD. I know how to get the right VOB & IFO files using DVD Shrink for each individual episode but what do I set my output size to for each episode? You have listed 1300mb & 4300mb for full movies but what about a 1/2 or 1 hour episode? On the internet these files are usually 400-700mb long. Should I just make it 700mb per episode? Will the software handle this number? Please advise.
     
  5. mactavish

    mactavish Member

    Joined:
    Jun 17, 2008
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    16
    Actually you don't need to set the conversion to a specific size unless you are going to burn the avi to CD or DVD. If you are planning to just stream the avi just set custom size=4598, I discovered that autogk will determine the size for you that will give the best quality video and audio.
    The avi you get on the torrents are 700 mb but the audio is only stereo. I like preserving the ac3 6 channel track
     
    Last edited: Jun 19, 2008
  6. duh

    duh Member

    Joined:
    Dec 12, 2002
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    11
    hey mac, I have tried two different movies, after removing codecs, wild hogs, hp goblet fire, both look better than an mp4, but the audio is not timed right, and these both worked for me in mp4 form, any ideas, thanks
     
  7. mactavish

    mactavish Member

    Joined:
    Jun 17, 2008
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    16
    hey duh i read more about your out of sync problem, what did you select in advanced settings -> audio output? there are four options, auto, original, VBR and CBR. choose ORIGINAL

    and for step 2 waht audio track did you choose? usually you will see AC3 6CH (for 5.1 audio) and AC3 2CH...choose the 6CH if you want the dolby digital audio, and 2CH for stereo only

    i read in one of the forums that one guys audio output was set to VBR which was the cause of the out of sync, try selecting ORIGINAL instead

    another post i read was the type of DVD ripper used can cause the out of sync problem, some rippers include part of the DVD menu which causes the syncing problem. AnyDVD and DVD Fab can cause this problem.

    duh what program do you use to rip the DVD?

    i use this program (download here 900kb). it is also free. after you install the program, insert your DVD you want to back up, then start DVD Decrypter and press the I button on your keyboard to start the IFO mode.

    [​IMG]

    you will aslo see cells that are checked. if more than one cell is checked, uncheck all cells except for the last one.

    also access the Settings, click on the IFO Mode tab, and make sure that both options in the File Names section are checked:

    [​IMG]

    now click the green arrow to start the DVD rip.

    open autogk, open the location of the ripped DVD for the INPUT FILE box, choose the vtsxxxx.ifo file (DON'T use the vtsxxxx.vob file)...do the other steps and convert it. What you can do instead waiting 2 hours for the conversion is click PREVIEW button. It takes 10-15 minutes for the preview to start playing and here you can check to see if there are any out of sync issues.

    did you remove the codecs after you installed autogk?
    how long does your conversions take? mine takes 2 hours

     
    Last edited: Jun 22, 2008
  8. mactavish

    mactavish Member

    Joined:
    Jun 17, 2008
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    16
    for DVDs with episodes...use the dvd ripper program in the above post. use the IFO mode...you have to rip each episode individually...you will see PGCs that are 20 min or 40 min and these should be the episodes.

    hope this helps you out
     
  9. mactavish

    mactavish Member

    Joined:
    Jun 17, 2008
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    16
    duh i had the same out of sync audio problem as you when i tried to rip the DVD of '21'. the way i solved the problem was I used IFO mode in DVD decrypter (download here). I noticed there were 7 cell pads. Other DVDs that i ripped only had one cell pad...i unchecked the first 6 cell pads, left the last cell pad checked and ripped the DVD.

    [​IMG]

    i ran atuogk, but before I started the conversion, I clicked preview (it took 5 min) and the preview was in sync so i started the conversion.
     
    Last edited: Jun 22, 2008
  10. duh

    duh Member

    Joined:
    Dec 12, 2002
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    11
    hay mac, thanks, this looks great,and audio is right, only one hickup on my first run with this procedure, I converted ratatouille, and it cut off about the first minute or so, I only selected one ( the largest ) pgc. is that correct. thanks
     
  11. duh

    duh Member

    Joined:
    Dec 12, 2002
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    11
    I spoke to soon, my second attempt would be good, but the scenes every now and again will get really jerky, its not the original because the disc is brand new, I never saw that section in ifo where I think you selected angle, and something else I can't remember, could this be contributing, thanks
     
  12. BryanNH_3

    BryanNH_3 Regular member

    Joined:
    Jan 15, 2007
    Messages:
    162
    Likes Received:
    0
    Trophy Points:
    26
    I wrote in at the beginning of this thread stating the same exact problem - no resolution to it either, unless you use a method that compresses the videos. Let me know what you come up with; it seems to happen to only some DVDs, yet not others ...
     
  13. mactavish

    mactavish Member

    Joined:
    Jun 17, 2008
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    16
    bryan i think i got a solution to the audio sync problem.

    the 'Ruins' DVD has 5 cells in IFO mode using DVD decrypter. cell 1:25sec,cell 2:30sec, cell 3:12, cell 4: 1min4sec and cell 5:7min 30sec. I left all cells checked and the DVD converted without any audio sync problems.

    on the other hand, the '21' DVD has 7 cells, cell 1-6: all are 0.15sec, cell 7: 1min. If I leave all cells checked, rip then convert i get audio sync problems. BUT if I uncheck all the 0.15sec cells and leave only the cell 7 checked the audio sync problem is solved. like here in the picture below

    [​IMG]

    try using IFO mode with DVD Decryter and uncheck any cells less than 1 sec. I believe this will solve the audio sync problem. I am looking for other DVDs I can convert that have these cells that cause out of sync audio. If I can resolve the out of sync audio using this technique (unchecking cells less than 1 sec) then audio out of sync is solved.
     
  14. mactavish

    mactavish Member

    Joined:
    Jun 17, 2008
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    16
    hey duh, yeah choose the largest PGC but usually DVD decrypter picks the largest automatically. Also don't forget to check the CELLs too. These cells are whats causing the audio sync.

    i just finished converting different DVDs like ruins, kingdom, and 21 to check for out of sync audio problems after conversion.

    with 21, i said I unchecked all the Cells except the last one and the out of sync audio was fixed.

    but then when I converted the Ruins DVD , I didn't need to uncheck any cells and there was no audio sync problem.

    I found out if you place the mouse pointer over the Cell, in DVD decrypter, it shows you the duration of the cell. when I checked the Ruins DVD, all the cells were 12sec - 1min.

    when I checked the cells of the 21 DVD, all 6 cells were 0.15 seconds, except cell 7 which was 4 min.

    so i think any cell that is less than 1 second should be unchecked.

    check the ratatouille DVD, how many cells are there? tell me what are the durations for each cell, try unchecking any cell that is less than 1 second. any cells > 1 second leave checked.

    oh and preview before starting the actual conversion to save time, It takes 10 minutes before the preview of the movie starts playing so just wait for it (you might think autogk froze but it didnt) then you can check if audio is out of sync before you do the actual conversion
     
    Last edited: Jun 24, 2008
  15. duh

    duh Member

    Joined:
    Dec 12, 2002
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    11
    well I have actually done that with the cells, and so far have not had an issue with audio sync since then, the two problems I have seen since using this method include missed intro ( about a minute ),and erratic scene pauses( then its like it speeds up for a second to catch up), similar to scratch on dvd but it is from a brand new dvd, I do have anydvd installed still, although I am using dvd decrypter, anydvd scans it( it works much better than decrypter for defeating encryption ) is is necessary to uninstall it? thanks
     
  16. mactavish

    mactavish Member

    Joined:
    Jun 17, 2008
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    16
    duh what is the size of your conversions? and what value do you use for custom size? when i used custom size=4598 and converted videos > 2gb i get jitters and pauses in the video while streaming. so don't do that.

    use CUSTOM SIZE=1399 for output size in autogk. this should give you an avi file thats 1.4gb. this should fix the jittering. Also i think you should uninstall anydvd for now.

    right now I'm converting the transformers DVD, its 3 hours, so i set the custom size to 2099. I will check to see if there is jittering with files streamed to the xbox 360 that is 2 gb or over. I remember reading in the autogk tutorial that xvid avi should not be more than 2gb.

    I will post here if the transformers jitters or not, when i stream it to the 360.
     
    Last edited: Jun 24, 2008
  17. mactavish

    mactavish Member

    Joined:
    Jun 17, 2008
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    16
    bryan check out this quick 10-second avi sample (download here 13mb). It is compressed but the quality is just like DVD. stream this to your xbox 360 using windows media player 11 (enable library sharing and set xbox 360 to allow), and turn on your htib to hear the 5.1 audio.
     
    Last edited: Jun 24, 2008
  18. mactavish

    mactavish Member

    Joined:
    Jun 17, 2008
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    16
    duh i finished converting the transformers DVD using custom size:2099. file size was 2.1gb and there was pausing and jittering when i streamed it to the xbox 360.

    I will try to convert the avi just under 2 gb using custom size:1953 this time. im converting now. ill post in 2 hours on how the streaming went. if this doesnt work i know that all the dvds i converted with custom size:1399 had no jittering and pausing so i will try that next (using custom size 1399).
     
  19. mactavish

    mactavish Member

    Joined:
    Jun 17, 2008
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    16
    update on the transformers DVD conversion using custom size:1953 (avi filesize 2 gb) in autogk:

    I am streaming the avi to the xbxo 360 now and there hasnt been any jittering or pausing. I am 20 min into the movie.

    duh, set your autogk custom size to 1399 for ratatouille DVD conversion.

    2nd update: 1 hour into the movie, still no ore jittering and pausing.

    3rd update: finished watching the avi. no jittering or pausing.

    keep the avi file size at or under 2 gb to solve jittering and pausing
     
    Last edited: Jun 24, 2008
  20. duh

    duh Member

    Joined:
    Dec 12, 2002
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    11
    hey I tried at 1958 or 53 whichever it was, and it took care of the jittering problem looks great, thanks, but for ratatoiullie it still skips about the first minute or so, it isn't the original disc because when I converted using vob files the first minute was there,I have tried the preview and it goes to the same spot, any ideas, thanks
     

Share This Page