1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

uTorrent still not green after forwarding port

Discussion in 'Windows - P2P software' started by ryberg31, Jun 20, 2006.

  1. ronvey

    ronvey Member

    Joined:
    Feb 9, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    11
    I have been using the guide on portforward.com to setup a static IP and forward the ports.

    I have the UPnP, NAT-PMP and randomize port options disabled in uTorrent. I have also tried with UPnP and NAT-PMP on.

    I have a Prolink Hurricane 9000C modem.

    There is a firewall option on the Linksys WRT54G router and I have tried with that disabled too.
     
  2. jeffw224

    jeffw224 Regular member

    Joined:
    Jun 26, 2007
    Messages:
    731
    Likes Received:
    0
    Trophy Points:
    26
  3. ronvey

    ronvey Member

    Joined:
    Feb 9, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    11
    [Ok, so the modem has a router function. It also has a port forwarding option:

    Virtual Server Configuration
    ID, Public Port - Start, Public Port - End, Private Port, Port Type, Host IP Address

    (Prolink Hurricane 9000C/P User Manual)

    Does this mean I have to forward the ports both in the modem and the linksys router?

    What Host IP Address should I use while forwarding the port in the Modem?

    Thanks.]

    Hey, thanks. Will have a look at the links.
     
    Last edited: Feb 9, 2008
  4. ronvey

    ronvey Member

    Joined:
    Feb 9, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    11
    Ok, I have managed to configure the two router setup so now I can see a green light on the uTorrent client.

    But when I check on 'speed guide' if the port is being forwarded properly, it still says that the port does not appear to be open. (Even with windows firewall disabled)
     
  5. mistycat

    mistycat Active member

    Joined:
    Nov 3, 2003
    Messages:
    3,142
    Likes Received:
    0
    Trophy Points:
    66
    Here's one possibility. When first configured through my router, a port check never showed anything but port closed for a week or two and which I knew couldn't be right. Connections in utorrent took about 10 - 15 minutes to show a green light but after that week or two, port check went green and a green connection light showed in a few minutes. Things have been fine ever since but could never be explained, even by the developer of utorrent.
     
  6. jeffw224

    jeffw224 Regular member

    Joined:
    Jun 26, 2007
    Messages:
    731
    Likes Received:
    0
    Trophy Points:
    26
    ronvey
    If you are getting the green in uTorrent, you are probably OK.
    If you have PeerGuardian, then the uTorrent site is on their blocklist and the port test will show blocked if PeerGuardian is active.
    If you have PeerGuardian, you need to disable it while taking the port test.

    I had a similar situation to Mistycat with my Azureus.
    My status in Azureus showed green and everything ran fine, but I kept failing the port test.
    I just stopped checking. However about 3 months later I checked and was getting an OK on the port test.

    As long as you are getting green in uTorrent and decent speeds, I would not mess with any settings on the routers/firewall.

    You can also use the speed guide screen to adjust your uTorrent settings to their optimal for your speed.
    There is a link to a speed test there.
    You should stop all internet activity, including torrents, before taking the test.
    You should take the test a few times to get a reliable average.
    It is your upload speed that is important for adjusting.
    Pay attention to whether the result is listed in kilobits (kbs) or kilbytes (kBs) as 8kbs = 1kBs.

    Once you have an average upload speed, you can return to the Speed Guide screen and choose a setting matching your upload speed from the pulldown menu-Connection Type.
    The speeds on the pulldown menu are listed in kilobits (kbs).
    The rest of uTorrent shows speeds in kilbytes (kBs).
    Once you have done this and pressed the Use selected settings button, utorrent will adjust your settings automatically to their optimal.

    Also, since you have forwarded your routers, check at Options/Preferences/Connection and make sure the options Randomize port each time uTorrent opens and Enable UPnP port mapping (as well as NAT-PMP) are unchecked (disabled).
     
  7. Silverion

    Silverion Member

    Joined:
    Feb 11, 2008
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    11
    Hey guys...Im new here

    On my uTorrent I am getting low speeds (50kb/s)
    I have tried forwarding a port and it doesnt work. I still get the red icon.

    1) Any
    2) I got a static IP of 192.168.1.136
    3) Netgear WGR614v7
    4) Roadrunner
    5) Norton Internet Security (allowed uTorrent)
    6) 2-3

    I tried that port forwarding website and it didnt help as above. Im just sick of getting such low speeds when others are getting 500+

    Thanks for any help
     
    Last edited: Feb 12, 2008
  8. mistycat

    mistycat Active member

    Joined:
    Nov 3, 2003
    Messages:
    3,142
    Likes Received:
    0
    Trophy Points:
    66
    Aren't RR and Time Warner the same company, I thought I read that TW was going to start blocking p2p? Anyway, disable UPnP and randomize port at options>preferences>connection. Make sure not to use the default port, use one over 10,000 and enable Protocol Encryption: http://forums.afterdawn.com/thread_view.cfm/395674 Make sure the Windows Firewall isn't blocking you and check at Port Forward for your Modem, it may contain a Firewall. If that's a Wireless router and you connect that way, try connecting directly if you can.
     
  9. Silverion

    Silverion Member

    Joined:
    Feb 11, 2008
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    11
    I disabled and enabled all those settings in preferences.

    ATM, our setup is RR modem > router > comps.
    I am hardwired to the router, but idk if the modem or router have a firewall. Also when I run the port test it says
    checking 59733 on 24.97.xx.xx
    ERROR....etc. you know the drill

    but my Static IP (yes im sure it is static, it stayed the same when I rebooted) is 192.168.xxx.xxx not 24.xx.xx.xx.xx

    Man this is soo annoying. It takes 1+ days to download a 4 gig file. Lately Im at 100 kb/s but thats still not the 500 many are getting

    Please help guys
    Thanks
     
    Last edited: Feb 12, 2008
  10. mistycat

    mistycat Active member

    Joined:
    Nov 3, 2003
    Messages:
    3,142
    Likes Received:
    0
    Trophy Points:
    66
    Most router's contain firewall's, you need to forward a port to it. Did you mean a Netgear WGR614v7, if not, contact the manufacturer? The speed's you will get are dependent on your connection, more or less than 500 kb are possible, I see about 350 kb/s on a 3 MB connection.
     
  11. mistycat

    mistycat Active member

    Joined:
    Nov 3, 2003
    Messages:
    3,142
    Likes Received:
    0
    Trophy Points:
    66
    Here's another possibility for that router. If it is a WG614v7, try this, go to Command Prompt where you got the info for your static address and make a note of your Default Gateway. Type that in a Browser window (use IE ) and see if you can access your router, the username and password may be admin and password. You may find a Netgear router similar to yours at Port Forward to guide you and other usernames and passwords as well. It's not as far fetched as it seems, I had to do exactly this with my D Link when Port Forward didn't list it.
     
  12. Silverion

    Silverion Member

    Joined:
    Feb 11, 2008
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    11
    no, port forward has my router there.
    Yea, its the WGR614v7 i believe

    The only thing is that I made a static IP (it works) and then forwarded the port from uTorrent and told the router (by signing in on the web) to forward the same port, but utorrent still says its not forwarded.

    ATM Im getting about 100-150 kb/s on a 1mb connection

    Also, if the router or modem have a firewall is there a way to bypass it??
    Also, if i connected my computer directly to the modem will I see a difference? Would it be easier to set up a Static IP and forward a port that way?
     
    Last edited: Feb 12, 2008
  13. mistycat

    mistycat Active member

    Joined:
    Nov 3, 2003
    Messages:
    3,142
    Likes Received:
    0
    Trophy Points:
    66
    By forwarding a port to your router, you have bypassed its firewall. A static ip and unchecking randomize port just ensures they can't change on you when you reboot with a router or restart utorrent and aren't necessary on just a modem unless it too has a firewall where you need to forward one port and still uncheck randomize port. Connecting directly to your modem should allow you to connect and see a green light but I once had a 1.5 MB connection and maxed out at 160 kb/s. I don't know a lot about modems but it may be listed at Port Forward if it has a firewall or Google it but those speeds you see seem correct.
     
  14. Silverion

    Silverion Member

    Joined:
    Feb 11, 2008
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    11
    my bad
    I double posted...see reply below

    Sorry
     
    Last edited: Feb 12, 2008
  15. Silverion

    Silverion Member

    Joined:
    Feb 11, 2008
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    11
    Ok. Thanks for the replies

    I've worked through a couple things.
    1) The router does have a firewall I believe
    2) The modem does not.

    But I have a question, to find my IP adress do I use my Internet Port IP Address or my LAN Port IP Address?
    I ask this because when I found the "external" IP address it was the same as the IP address that Utorrent test 24.97.xx.xx. Could this be the modem blocking me or something?
     
  16. mistycat

    mistycat Active member

    Joined:
    Nov 3, 2003
    Messages:
    3,142
    Likes Received:
    0
    Trophy Points:
    66
    Use the ip address you set static and see at ipconfig/all in Command Prompt. As to your modem blocking, I would doubt it. With your router listed at Port Forward, it has a Firewall (most do) and needs to be forwarded.
     
  17. Silverion

    Silverion Member

    Joined:
    Feb 11, 2008
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    11
    Yes i know....(man i guess its my fault im not clear enough)

    I forwarded a port and followed all the instructions.
    Only problem is that when I go to test the port on Utorrent it checks port 59733 on 24.97.xx.xx and comes up as failing.
    I went back and double checked everything. I have a working statip IP on the computer and forwarded the port through there, but nothing

    UPDATE: I turned off the computers and the router and turned it back on. When i started Utorrent i had a green checkmark (YES!!!!) but in less than 10 seconds it turned back to yellow and i tried the test again and failed
     
    Last edited: Feb 12, 2008
  18. Silverion

    Silverion Member

    Joined:
    Feb 11, 2008
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    11
    Hey guys...thanks for the help

    Im not sure what happened but I looked again and I had the green light again. Also it says the port is okay.

    So it worked itself out. YAY!!!!
     
  19. mistycat

    mistycat Active member

    Joined:
    Nov 3, 2003
    Messages:
    3,142
    Likes Received:
    0
    Trophy Points:
    66
    Utorrent checks a port to your router (external ip) but you forward your computer (static ip) to your router. Sounds like your ISP is blocking you but your speeds seem fine ( I wouldn't doubt it if they are connected to Time Warner). See if anything in this torrent jpg applies. I think it used to be called the Torrent Firewalled Flowchart and lists possible Firewall causes to check as you go through it: http://www.plucky.org/component/option,com_vfm/Itemid,54/
     

Share This Page