1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

What is wrong?

Discussion in 'PS2' started by abx, Feb 21, 2005.

  1. abx

    abx Guest

    Yesterday my ps2 was working great. I have a mod chip and HD advanced with a 200gb Maxtor hard drive. This morning when I put a PS2 DVD game in (original not backed up) I got the blue BROWSE and SYSTEM CONFIGURATION page. I selected the X in an attempt to read the DVD and got NO DATA. READING DISK is displayed and continues to blink. I pressed the top button on my PS2 in an attempt to reset it. I unplugged it and tried it again. I tried a backup DVD and the HD Advanced disk. I still get that NO DATA screen that I believe is called the "Red screen of death". My guess is the laser is bad but I don't want to spend the time or the money to fix it until I can find out for sure. What do you guys think is wrong? Is there a way to determine what is wrong? Thanks for any Input.
  2. steimy

    steimy Active member

    Dec 2, 2004
    Likes Received:
    Trophy Points:
    Wow, thats F'ed up! Never heard that one before.
    Wish i could help you out, hope someone can.
  3. Dix_Fix

    Dix_Fix Regular member

    Jan 2, 2005
    Likes Received:
    Trophy Points:
    If the laser is stuffed the unit would still play games stored on the hard drive!Also the RSOD is the red screen that comes up when U have a backup in the drive & the PS2 knows it's a backup. It says something like put in a PS2 original disk. So describe in more detail EXACTLY what your system does, from when U put the power on till U give up in disgust. Including any noises it makes & when it makes them.
    Vini vidi vici
  4. qbano

    qbano Member

    Mar 27, 2004
    Likes Received:
    Trophy Points:
    before buying a laser
    1. pull the hdd out
    2. disable/turn off the chip (sleep mode)
    3. try original game
    4. try dvd movie
    5. try music cd

    if you get no data on all three buy a laser..
    what version ps2 is it???
    Last edited: Feb 22, 2005
  5. abx

    abx Guest

    Thanks everyone


    I cant use my hard drive because I need to use HD Advanced first to play games and my PS2 can't read it.

    When I put a game in:
    -I get the blue BROWSE and SYSTEM CONFIGURATION page.
    -I selected the X on the controler in an attempt
    to read the DVD.
    -The screen turns a whiteish color and says NO
    READING DISK while blinking
    -It makes a grinding sound while trying to read
    the DVD and contiues to says NO DATA READING
    DISK while blinking
    -I say a couple four letter words
    -I get another beer.

    Last edited by a moderator: Feb 22, 2005
  6. hks123

    hks123 Member

    Jan 27, 2005
    Likes Received:
    Trophy Points:
    I have the same problem after I instlled a magic 3.1 on my ps2 V4, i don't think it's the laser becasue when I put a orginal game in it will read it as a ps2 disc, (says ps2 disc on the top of the screen) and ask me to press x(enter) I did and it will read the disc again then back to the same screen again, when I put in a back up it say NO DATA, reading disc.......
    I thinking it might be the chips
  7. abx

    abx Guest

Share This Page