AfterDawn Forums

xvid_encraw

This discussion thread has 4 messages.

#1
Hi,
I am trying to run an example on Evalvid, under Linux.
According to the instructions of the example in the link:
http://140.116.72.80/~smallko/ns2/myevalvid2.htm
I wrote in the shell :

./xvid_encraw -i akiyo_cif.yuv -w 352 -h 288 -framerate 30
-max_key_interval 30 -o a01.m4v

I need to download the Xvid_encraw in order to do it.
Do you know where can I find it?
please help me a.s.a.p
Thanks a lot.

ves.*
▼▼ This topic has 3 answers - they are below this advertisement ▼▼
AfterDawn Advertisement
#2
xvid.. standard codec.. encraw is actually a switch function meaning encode raw (you are trying to make a mp4 video file from raw YUV after all ..

if you have w32 codecs pack or ffmpeg installed you just need to make sure it's in your path..

http://www.xvid.org/Xvid-Codec.2.0.html

I don't really get why you are doing this .. trying to run a trial video streaming evaluation tool while quite obviously lacking certain key pieces of understanding.. try reading ALL the linked pages again.. and working in a methodical manner.. ALL the codecs and other bits and pieces should be built from the sources linked from the page listed.. otherwise it's very likely there will be version conflicts and errors.

also note.. the command you are using is for cygwin environment, in all likelyhood things aren't going to work properly in any other operating system environment without some major tweaking (as the author says.. download necessary software .. and nothing further) .. so from there on you are totally alone

It would help greatly if you could show the error you are getting.. and the location of your codecs in relation to the $path environment you are currently in.



ARR! Them pesky Navy! Get out of my sea!
irc://irc.villageirc.net/afterdawn http://www.pirateparty.org.uk/
#3
Hi,

The location of xvidcore is in myevalvid2, the current directory .
The error I got:

@ubuntu-desktop:~/ns-allinone-2.34/ns-2.34/myevalvid2$ ./xvid_encraw.dsp -i akiyo_cif.yuv -w 352 -h 288 -framerate 30 -max_key_interval 30 -o a01.m4v
bash: ./xvid_encraw.dsp: No such file or directory

What is missing?
Many thanks for your help.
#4
./xvid_encraw.dsp .. it either doesn't exist or isn't in your $path .. I get the strangest feeling that command string is nothing like right.. ./ is usually used when running something as root rather than as user.. try invoking it as simply


 xvid_encraw.dsp -i akiyo_cif.yuv -w 352 -h 288 -framerate 30 -max_key_interval 30 -o a01.m4v 





ARR! Them pesky Navy! Get out of my sea!
irc://irc.villageirc.net/afterdawn http://www.pirateparty.org.uk/
This discussion thread has been automatically closed, as it hasn't received any new posts during the last 180 days. This means that you can't post replies or new questions to this discussion thread.

If you have something to add to this topic, use this page to post your question or comments to a new discussion thread.