1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't extract audio without the right codec, but what is it?

Discussion in 'DivX / XviD' started by Vicx19, Feb 23, 2007.

  1. Vicx19

    Vicx19 Member

    Joined:
    Oct 27, 2004
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    16
    I opened an MKV move in vdub mod so I can extract the 2nd audio stream (jap) and re-encode the movie as XVID minus the 1st audio stream (eng).

    When I try to extract it I get this: Error initializing audio stream decompression, the request conversion is not possible, check to make sure you have the required codec.

    I can play the sound, but I just can't extract it.

    So how do I know which codec to get, and where to get it? I haven't had this problem before.
     
    Last edited: Feb 23, 2007
  2. celtic_d

    celtic_d Regular member

    Joined:
    Jan 23, 2005
    Messages:
    3,352
    Likes Received:
    0
    Trophy Points:
    46
    You don't need to decode it to extract/demux it. You only need a decoder if you want to decode and in the case of VDubMod you need an ACM decoder. Probably your audio is aac (think VDubMod can internally handle vorbis) and there is no working aac ACM decoder that I know of.

    Better to use mkvextract then VdubMod for extracting mkv files.
     
  3. Rikoshay

    Rikoshay Regular member

    Joined:
    Apr 13, 2004
    Messages:
    307
    Likes Received:
    0
    Trophy Points:
    26
    Actually, the best thing you can do is keep it in the MKV format.

    More than likely, the Video codec format is most likely XviD already, and the audio for the Japanese is probably 5.1 HE-AAC (which a lot of anime in this format setup is).

    A while back I would have thought the same thing, but I've finally gotten my setup perfect as to it playing Jpn audio tracks over the Eng ones.

    What you need is:
    -Media Player Classic
    -Haali Media Spliter
    -A recent release of FFDshow

    First, set them all up to run. I assume you know what to do there, so I'll skip to how you should set them up for it to work.

    Open Haali Media splitter, and under Options > Input, put Yes to Load embedded fonts, and no to Merge all segments.

    This is the important part. Under Languages, under Audio Language priority, put jpn,eng in that area, for Subtitle Language priorty, but eng or whatever you want, and under Audio and Subtitle Languages, put jpn,eng again. Also, if you want, go to Interface > Show tray Icon and put No.

    Now open Media Player Classic and go into options either through View > Options or just pressing O.

    Under Playback > DVD/OGM, and where it says "Preferred language for...", for menu make it English, for audio make it Japanese, and for Subtitle make it English again.

    Now go to Output, and under Direct Show Video, move the bullet to VMR9 (renderless) and check the box "Lock back-buffer before presenting...".

    Under Internal filters, uncheck all of these from both sides, AVI, Matroska, MP4/MOV, Ogg, Real Media and AAC. Go to Audio switcher, and check "Enable built-in audio switcher filter...", "Normalize", and "Regain Volume".

    Under External Filters, search for ffdshow Audio Decoder and when it shows up there, mark the bullet Prefer on the right.

    This next step is optional but I would use this or set it up to whichever style you prefer. Under Subtitles, Place the Vertical override placement at about 98% if you have a full screen monitor or 94% if you have a wide screen one. Under Default Style you can change the color of the subtitles that play; I personally prefer Yellow primary and if there's a secondary I put Teal, then I put Arial 16pt as the font. After you do all that hit Apply and OK.

    Now to set up FFDshow. I'm pretty sure you may have an idea of how you want to set up your ffdshow Video decoder, but I'll make a quick run through as to how I set it up.

    In Codecs, I just enable FFDshow to play it from XviD to FLV1 in that list. Go to Info & Debug, and in there, check the box "Don't use ffdshow in:". Also, in Tray, dialog and paths, uncheck "show tray icon" if you don't want it there.

    I enable Postprocessing, enable automatic quality control, Processing strength to 112%, and under processing method, have mplayer, Luminance, and Full Luma range checked.

    I put Saturation to 84 under Picture properties.

    Under sharpen, I put unsharp mask on and put it to 16. You can make any changes you see fit here, but these settings usually give a nice, crisp look.

    Now for Probably the most important part, setting up ffdshow Audio decoder.

    If you prefer to use a different MP3 decoder, then skip my advice about it here, but I use mp3lib to run it in FFDshow. In Codecs, put libavcodec for Vorbis and AMR, and put libfaad2 for AAC.

    Go down to Volume, enable it, check Decibels scale, check Normalize, and put Buffer length to 384.

    You can check mixer and put the Output speakers config to 2/0 if that's all you support, or change it to whatever you can support.

    And that about covers it. MPC should open MKV files that have this setup to play the Japanese audio files automatically. If you still insist on removing the English dubs from the file, follow celtic_d's advice and get mkvextract since I don't know if Virtual Dub Mod fully supports MKV anymore. Just look for the audio stream that seems to be the English version and remove (demux) it.
     

Share This Page