1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't play any video type nor install any codecs....

Discussion in 'Video playback problems' started by samurai27, Oct 14, 2004.

  1. samurai27

    samurai27 Member

    Oct 14, 2004
    Likes Received:
    Trophy Points:
    I resentaly got a video file that I did not have the codecs to play it. So I searched for it and found one but it was different than the other codecs I have installed on my computer. It told me that since I have windows me I had to unzip them in to c:\windows\system and open up one of them that was like "install_register" or something so I tied it and it said in a the ms-dos box that it was a bad command. So I tried again and got a message box that said something like "D llRegisterServer in CoreAAC.ax failed Retern code was 0x80040154" so I deleted those files from there thinking that they did not work. But then some of the video files I was previously able to play would not work and the excuse the player gave was "Unknown Exception caught" so I eventually came to the conclusion that I screwed up some of other codecs that I had in c:\windows\system. So I uninstalled all of the codecs I had and the player I usally use and tried to reinstall them, the player installed fine but still would not play any thing so then I tried to reinstall some of the codecs I had on it but as it almost finished an error poped up and said "c:\windows\system\xvid.ax Unable to register the DLL/OCX: DllRegisterServer failed; code 0x80040154 Click retry to try again, Ignore to proceed anyway (not recommmended), or abort to cancal installation" I tried retry many times but the same thing keep pop up again and again. So I was wondering if anybody could help me to fix it? Thank You.
  2. andmerr

    andmerr Guest

    Maybe check the link out below:


    I also ran across this little bit of info on another site which might enlighten you

    As a temporary measure do this:

    1. Copy the MSMAPI.OCX into the WINDOWS\SYSTEM32 directory
    2. Start Menu, Run, and type this REGSVR32 c:\windows\system32\MSMAPI.OCX (use the full path where the file is copied)
    3. You should get a message from windows that the DLL has been registered.

    Now unless the OCX depends on other files that are missing, your code will work.

    You can do this with most OCX files.

    > > It has two ole controls MAPISession and MAPIMessage. It is working well on my computer.
    > > But when I try to run it on other computer it shows following error message
    > > OLE error code 0x80040154 class not registered, OLE object is being ignored, Record Number 3
    > > What is problem? How could I register this class to other computer?
    > You need to install and register the MSMAPI32.OCX file. It's often very wise to use an installer package such as InstallShield (ships with VFP!) to deploy your apps.
    > --
    > or you might want to send your question to

    Eric den Doop
    > www.foxite.com - The Home Of The Visual FoxPro Experts

Share This Page