1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Denied access to Network folder

Discussion in 'All other topics' started by boytool, Apr 3, 2007.

  1. boytool

    boytool Member

    Joined:
    Oct 13, 2005
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    16
    I know this isn't a digital or media question but I am running out of places to ask and I hope someone here will be able to help me.

    I have a network successfully running between two pc's.
    But...when I click on 'View Workgroup Computers' on the Main/Server, I get a message saying that access is denied, that I may not have permission, that I must ask the Admin for permission, and finally that the network path is not available.
    I can access My Network Places on the Main/Sever, but no further.

    All access is available on the Client.

    If this is too far offtopic then please boot me to somewhere more appropriate.
    Thanks.
     
  2. Dunker

    Dunker Regular member

    Joined:
    May 8, 2006
    Messages:
    1,444
    Likes Received:
    0
    Trophy Points:
    46
    Ooops, double-post, see below.
     
    Last edited: Apr 4, 2007
  3. Dunker

    Dunker Regular member

    Joined:
    May 8, 2006
    Messages:
    1,444
    Likes Received:
    0
    Trophy Points:
    46
    See if "Simple File Sharing" is enabled. You will find this under My Computer->Tools->Folder Options->View and it's at the bottom on XP Service Pack 1.

    Alternatively, if it's not, you can set permissions for the specific folder to allow "Everyone" full read access (and write and modify too if necessary). You can create an Access Control List if you want to restrict access to certain users, but that's more involved.
     
  4. boytool

    boytool Member

    Joined:
    Oct 13, 2005
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    16
    Hey
    Couldn't find Simple File Sharing or XP Service Pack 1 in that dropdown list ("and it's at the bottom on XP Service Pack 1 ").
    Not got anything like it.

    If you could take the time to show me the way to alter the Access Control List............
     
  5. Dunker

    Dunker Regular member

    Joined:
    May 8, 2006
    Messages:
    1,444
    Likes Received:
    0
    Trophy Points:
    46
    Here you go. This tells you step-by-step what to do. Bear in mind that this only applies to Windows XP Pro. As a rule, and what I'd recommend differently than the Microsoft Knowledgebase article I gave you the link to above, is that you would only specify a specific user (e.g. you) rather than Allow Everyone and pick specific users to deny.
     
  6. boytool

    boytool Member

    Joined:
    Oct 13, 2005
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    16
    This isn't working.
    To begin with, the folder which contains the two Workgroup Computers is not available to select in Explorer: I get the same error/denial as before.
    From the folder tree on the leftside, I click My Network Places, Windows Network, FSNetwork (my name for the network), which then refuses to open, goes 'Bong' and gives me the denial message.

    Because I wasn't seeing any Security tab for any folders I followed a link in the thread you gave, and got this:

    "To display the Security tab
    Open Folder Options in Control Panel. (Click Start, click Control Panel, click Appearance and Themes, and then click Folder Options.)
    On the View tab, under Advanced settings, clear the Use simple file sharing [Recommended] check box" just like you suggested earlier. But....
    I Don't Have That Checkbox!

    Something is very odd, either with my install of Windows or the way I set up the Network.
     
  7. Dunker

    Dunker Regular member

    Joined:
    May 8, 2006
    Messages:
    1,444
    Likes Received:
    0
    Trophy Points:
    46
    Which Service Pack do you have?
     
  8. boytool

    boytool Member

    Joined:
    Oct 13, 2005
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    16
  9. Dunker

    Dunker Regular member

    Joined:
    May 8, 2006
    Messages:
    1,444
    Likes Received:
    0
    Trophy Points:
    46
    Here's a tutorial from MS' site that might help. The video doesn't play on my machine, but it might on yours. Maybe your checkbox got relocated. I don't use SP2 that muh so I am not as familiar with it as SP1. If not then we'll try something else but try this first.

    Also, do all your workgroup computers actually have the same workgroup or domain? This might be the problem.
     
  10. boytool

    boytool Member

    Joined:
    Oct 13, 2005
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    16
    Will try it and get back.
    The workgroup has the same name: I can see both Client and Server from the Client so it must be a problem on the way the Server is set up.
    Thanks.

    Later:
    I have confirmed again that I do not have the checkbox in the Folder Options View dropdown list for "Use simple file sharing". Want a screen shot?
    What does this suggest to you?
     
    Last edited: Apr 11, 2007
  11. Dunker

    Dunker Regular member

    Joined:
    May 8, 2006
    Messages:
    1,444
    Likes Received:
    0
    Trophy Points:
    46
    Question, how are your firewalls, if any, set up? A one-way scenario that you just described, e.g. the client can see the server but not vice-versa, suggests that your firewall on the client may be interfering with the ability of the server to initiate requests to your client. Be aware that Windows' built-in firewall may also be running without your knowledge. Firewalls must be set up so your entire LAN is considered "trusted". It is possible to tweak some firewalls for added security, but it's best to try testing the client-server setup without firewalls. If you're really knowledgeable about them, it's possible to set up a LAN with them running, but if you're not, try running without them for a bit and see if your server can see your client.
     
  12. boytool

    boytool Member

    Joined:
    Oct 13, 2005
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    16
    Both machines have McAfee on them and both are configured to trust the whole network.
    The MS firewalls - although inactive - are also configured to allow full network activity.

    This couldn't be the cause anyway, surely, as the network is working properly. If one side were being blocked I couldn't send or fetch data.

    What do you say about the fact that I don't have the 'Simple File Sharing' option? That really is strange, n'est pas?

    I hope your patience lasts as long as your curiosity about this anomaly!
     
  13. Dunker

    Dunker Regular member

    Joined:
    May 8, 2006
    Messages:
    1,444
    Likes Received:
    0
    Trophy Points:
    46
    Try disabling the firewalls anyway, while you're disconnected from your modem. Firewalls CAN cause such problems; just because your network partly works doesn't mean they aren't interfering. Stateful packet inspection firewalls like McAfee are designed to run on client-side machines, not servers; they will normally block unsolicited traffic, which could explain the symptoms you are having. It's worth a try.
     
  14. boytool

    boytool Member

    Joined:
    Oct 13, 2005
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    16
    I don't know why this has happened now but it has.
    Yesterdays I reran the network setup wizard on the Server for the umpteenth time and hey presto! I saw my workgroup computers for the first time.
    From past experience this will be a transitory change, and it will go to hell in a handcart again sometime soon, but at least I can set things up proply.

    Thank you Dunker for your help.
     
  15. Dunker

    Dunker Regular member

    Joined:
    May 8, 2006
    Messages:
    1,444
    Likes Received:
    0
    Trophy Points:
    46
    You're welcome, but now I'm wondering exactly what changed! :) Well, working with computers for years I'm happy enough that they work, so I'd count my blessings...;)
     
  16. boytool

    boytool Member

    Joined:
    Oct 13, 2005
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    16
    I'm obviously more baffled than you.
    I didn't do anything - at least not consciously.
    The previous day I once got denied access to the workgroup computers on the Client, and on a couple of occasions saw only the Client pc and not the Server.
    The network is obviously not optimally set up but at least it's working. As you said, better that than nothing.
     
  17. boytool

    boytool Member

    Joined:
    Oct 13, 2005
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    16
    Whoowee!
    Denied access again.
    As long as the network works I no longer care.
     
  18. mglez86

    mglez86 Guest

    with service pack 2, you just go to the file folder you need to share, right click, properties, sharing, share this folder on the network, there will appear a wizard to configure acces, when it's done it probably will restart your pc, when it does do the same steps and there will be a check box that says something about sharing it, you give it a name for the network and it's all set, it will probably take some time for it to show or give acces on the net, some times it takes me about 10 to 15 minutes to actually see the folder on the other computers, and remember to set the computers workgroup to the same one x_x
     

Share This Page