1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MPEG2 trouble with TMPGenc

Discussion in 'MPEG-1 and MPEG-2 encoding (AVI to DVD)' started by jabber25, Feb 21, 2004.

  1. jabber25

    jabber25 Member

    Joined:
    Feb 20, 2004
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    11
    I am having trouble creating MPEG2 files with TMPGenc. It says that the file was successfully encoded, but when I try to play it with Windows Media Player, it plays the first couple seconds, then shuts WMP down. I've also tried burning it with Nero and playing the video on my DVD player, but the video is very very choppy and the audio is also choppy. Anyone able to help me, please?? Thanks!!!
     
  2. Minion

    Minion Senior member

    Joined:
    Sep 28, 2003
    Messages:
    5,768
    Likes Received:
    0
    Trophy Points:
    116
    Well First off Media Player isn"t really made for playing Mpeg2 files...You should really get a Software DVD Player Like WinDVD or PowerDVD to Preview Mpeg2 files as Media Player doesn"t Natively support the Format and it Just Plain sucks for Mpeg files...The Choppy Playback you are Experienceing on your DVD Player can be caused from a Few Things But the Most Common thing especially with Files encoded By Tmpgenc are "Bitrate Spikes"...Tmpgenc has a Nasty habbit of Not Following the Bitrate that you set in the Settings and the Bitrate will Sometimes Spike a Lot higher than it should..When a Bitrate Spike Occurs you DVD Player has to suddenly Spin the Disk reall fast so it can read the Increased Data rate But usually it can not Spin the Disk Fast enough because the Bitrate is Way to high for your DVD Player to Handle Hence causeing the choppy Playback....I have Found the only way to Prevent this From happening is to not use Tmpgenc...Other things that can cause jumpy Playback is if you encode the AVI file to Mpeg useing a Different Frame rate than the AVI file ,As Tmpgenc and Most other encoders can not Properly Convert Frame rates...Maybe you should get a DVD-Burner and then you will not have to worry about the Bitrate being too high for your DVD Player or Bitrate Spikes, you can get them for under $99 right now...Cheers
     
  3. jabber25

    jabber25 Member

    Joined:
    Feb 20, 2004
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    11
    Thanks Minion!

    Since you said you try to not use TMPGenc, what program would you suggest instead? Is there anyway to fix the problem in TMPGenc???
    Thanks
     
  4. Minion

    Minion Senior member

    Joined:
    Sep 28, 2003
    Messages:
    5,768
    Likes Received:
    0
    Trophy Points:
    116
    Well the MainConcept encoder has Much better Bitrate controll and it is a Much Faster encoder with about the same Quality, and simce your Player seems to be sencitive to Bitrate spikes you should use a CBR Encodeing method and do not set the Bitrate higher than the SVCD standard of about 2500kbs...Cheers
     
  5. jabber25

    jabber25 Member

    Joined:
    Feb 20, 2004
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    11
    Thanks again!! Is there a huge quality difference in using CBR as opposed to VBR??
     
  6. Minion

    Minion Senior member

    Joined:
    Sep 28, 2003
    Messages:
    5,768
    Likes Received:
    0
    Trophy Points:
    116
    Well if you set the VBR Setting Correctly you can get the same or better quality than CBR but with Smaller File sizes but it seems that VBR is probably causeing your Problems....Cheers
     
  7. jabber25

    jabber25 Member

    Joined:
    Feb 20, 2004
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    11
    Thanks once again! I was just told that the VBR makes a big difference... I guess if it's causing the problem though, I'll have to do without. But you also say it doesn't make THAT much of a difference. I'll give it a try with CBR. Thanks muchly!
     
  8. jabber25

    jabber25 Member

    Joined:
    Feb 20, 2004
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    11
    Another question...I've got MainConcept now, but when I encoded to SVCD format and burned it using nero, the video and audio are basically in "double time". If i play it normally, the video is choppy, but if I fast forward it it is much much smoother. What could be causing this? Is it my original avi file (which by the way, plays cleanly on my PC) or is it the encoding I did wrong??? Thanks!@!!!
     
  9. Minion

    Minion Senior member

    Joined:
    Sep 28, 2003
    Messages:
    5,768
    Likes Received:
    0
    Trophy Points:
    116
    What was the Framerate of your AVI file?? Because like most encoder you have to encode the File to the Frame rate of the Source AVI file..So if you want to encode a Pal AVI file to NTSC you can not do it Properly with the encoder..Or if your AVI is 23.976fps and you wanted to encode it to SVCD at 29.976fps then you would have to enable 3:2 Pulldown...Why don"t you Post the Specs of your AVI file and I"ll tell you the setting you should choose ....Cheers

    PS: when Burning your SVCD"s to CD-R make sure you burn them at the Slowest Speed Possible or you can have problems...And Play the Mpeg file before Burning it and see if it plays fine on your PC...
     
  10. jabber25

    jabber25 Member

    Joined:
    Feb 20, 2004
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    11
    Sorry... I am fairly new to this. Where do I find the specs of my AVI?? The MPEG seems to play fine on the PC, but when I burn it to CD the time length is almost twice as long as the file actually is. Thanks so much for the help!!
     
  11. Minion

    Minion Senior member

    Joined:
    Sep 28, 2003
    Messages:
    5,768
    Likes Received:
    0
    Trophy Points:
    116
    Well you can get some of the Specs of your File by simply right clicking the AVI file and going to "Properties" and you should be able to get information Like what codec was used to encode the file and the resolution of the File and the audio format and sample rate and the Length of the Movie and the Framerate of the File...But if the File Plays Perfectly on your PV before Burning it to CD-R then it makes me think something went wrong with the Burning or something...Did you make sure to Burn the CD_R as slow as Possible like 4X speed of 8X Max because VCD"s and SVCD"s do not have error correction data to fix Burn errors.....Good Luck
     
  12. jabber25

    jabber25 Member

    Joined:
    Feb 20, 2004
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    11
    Alright... here are the specs of the file:
    656 x 480
    44:38
    23 frames/sec
    268 kbps
    24 bit
    DivX Codec

    And yeah, the file plays fine on my preview and WMP detects it as 44:38, but when I add the file in Nero, it changes the length to 77:00 or something. I think this is where the problem is and is why I have to play it in fast forward mode on the DVD player. I just don't understand why it's doing this. The file i'm previewing is the one after encoding with MainConcept. Actually, as I'm typing this, I am trying to fast forward to the end of the MPEG file, but it keeps freezing the video but playing the audio. Maybe the MPEG is corrupt. Could you please let me know what settings I should use to encode and I will try again??? Thanks so much.. you've been a great help!!!
     
  13. Minion

    Minion Senior member

    Joined:
    Sep 28, 2003
    Messages:
    5,768
    Likes Received:
    0
    Trophy Points:
    116
    Hi ,It is normal for Nero to see the Length of your Mpeg file as being Incorrect because it Measures the Length by how much space the Mpeg file will take up on a 80 minute CD-R not by the Actual length of the Mpeg file, so if it says that it is 77 minutes then that just means that the Mpeg file is about 770mb and will take up 77 minutes of the 80 minute CD-R....
    Your Source File is a NTSC Film Source File so it has to be encoded at 23.976fps with 3:2 Pulldown..So to properly set up the Frame rate Settings for this File
    First load your source AVI file into MainConcept and set the "Mpeg type" to "SVCD" and "Video Mode" to NTSC" and then click the "Details" Button, Now under "Field Encodeing" set it to "Progressive Frame" and then set the "Frame Rate" to "23.976fps" and "deinterlaceing" to "None" and under "Search method" and "Search Range" set them to there Highest settings which are "15 and 31" respectively and now Click the "Advanced" Button and were it says "Frame Rate" set it to "23.976fps Film Rate" and under "Bitrate Type" set it to "Constant Bitrate", Now go to the "Multiplexor Settings" page and near the Botton were it says "Pulldown" make sure it is set to "3:2" ...Now we are basicly done with the correct Frame rate settings and you shouldn"t have any Playback Problems caused by incorrect Frame rate settings..Let me Know how it works out...Cheers
     
  14. jabber25

    jabber25 Member

    Joined:
    Feb 20, 2004
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    11
    Thanks once again... I followed all your settings, but when I clicked on Convert, it came up with the following two errors:
    V095:Invalid video frame rate (23.98fps) for SVCD, should be 25fps or 29.97fps
    V097:Invalid video vertical size (480) for PAL SVCD, should be 576
    Any idea how to get around these??? Thanks again!!
     
  15. Minion

    Minion Senior member

    Joined:
    Sep 28, 2003
    Messages:
    5,768
    Likes Received:
    0
    Trophy Points:
    116
    Well you have it set up for encodeing to Pal...Do you Live in Europe or in another Pal Country??? If not then you have to set the "Video Mode" to "NTSC" and then it should work Because I just set it up the same way I told you to with a 23.976fps AVI file and it started encodeing no Problem...If you do live in a Pal country then you are in a Bind because you can not encode a NTSC AVI file to pal useing most encoders unless you first convert the NTSC file to Pal and this can be quite Complex....Cheers
     
  16. jabber25

    jabber25 Member

    Joined:
    Feb 20, 2004
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    11
    So that was very wierd!! The video mode was on NTSC so I changed it to PAL and started. It started working, so I aborted and then changed it back to NTSC and it worked! Now, I just have to sit back and wait for it to finish. I'll let you know how it turned out. Thanks for the help!
     
  17. jabber25

    jabber25 Member

    Joined:
    Feb 20, 2004
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    11
    Alright, file again played fine on my PC, but when I burned it, the same problem. Very choppy, but when played in fast forward...smooth. I really feel it has something to do with how long the file is perceived to be in Nero??? Is that crazy? I can't figure this out... and I don't need any more coasters!!!!
     
  18. Minion

    Minion Senior member

    Joined:
    Sep 28, 2003
    Messages:
    5,768
    Likes Received:
    0
    Trophy Points:
    116
    Well I don"t know what the Problem can be ,Maybe your DVD Player doesn"t Like SVCD"s?? You should get a DVD Burner then you won"t have these sort of problems cuz out of the Hundreds of DVD"s I have Burned very few had any Problems at all and they are really cheap these Days ,I have seen them for $79 for a Dual Format 4X DVD Burner, You can even Put SVCD"s and VCD"s on DVD and they play in most DVD Players and you can get 3 movies on each DVD.....Good Luck
     

Share This Page