1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No Sound

Discussion in 'MPEG-1 and MPEG-2 encoding (AVI to DVD)' started by MidusZ15, Nov 13, 2004.

  1. MidusZ15

    MidusZ15 Member

    Joined:
    Nov 13, 2004
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    11
    I'm having a problem with TMPGENc. Whenever I encode to Mpeg-1 from Avi the sound doesn't show up. I searched around and found that TMPGENc has a problem with AC3, but I used Gspot and the files uses 0x0055(MP3, ISO) MPEG-1 Layer 3. I think is is ok, but any help would be appreciated.
     
  2. nownthen

    nownthen Regular member

    Joined:
    Nov 14, 2004
    Messages:
    752
    Likes Received:
    0
    Trophy Points:
    26
    I think you should extract the sound to wave. Virtual Dub works well for me. I have ran into the same problem before.
     
  3. aldaco12

    aldaco12 Active member

    Joined:
    Nov 6, 2002
    Messages:
    2,544
    Likes Received:
    0
    Trophy Points:
    66
    The problem is well known. You must:

    1) extract the .WAV with Virtualdub (File____Save WAV..), with Audio set on 'Direct Stream Copy'
    2) compress the .WAV to .MP2 with BeSweet + BeSweet GUI (use profile: .MP2 for SVCD)
    3) delete the .WAV, it's useless now
    4) multiplex the .MP2 with the TMPGenc's output video (that now shoukld have no sound)

    If Virtualdub had given you a warning about 'detected improper VBR encoding - rewrite it with standard CBR values during processing..." you should have done the same, but with Audio set on Full Processing Mode (that can't be used, if you can't decode the WAV. I don't know what to do if you have simultaneous 'improper encoding' and cannot decode the audio. I'm afraid in this case you should have to do it twice: the 1st with Virtualdub on 'direct stream copy' to enable you to 'decode' the sound, the 2nd with Virtualdub on 'full processing mode' to use CBR values on the sound ).

     

Share This Page