1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Ubuntu vs Samsung vs. Cellphone

Discussion in 'Linux - General discussion' started by funky01, Sep 17, 2012.

  1. funky01

    funky01 Member

    Joined:
    Jun 9, 2006
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    11
    I am operating Ubuntu 12.04 on an Acer Aspire One. I love ubuntu. To me, it is a God send especially out here in West Africa. My dealing with Ubuntu 12.04, it has the ablity to recognize any hardware device that is attached to it. Recently, my parent came for a visit, I took both of their Samsung Android cellphones and plug them into my netbook to retrieve some photos from it. Both of their devices was not dedected by Ubuntu. I ran a vitual michine on my system. Windows 7 could see their devices but did not have the drivers for both of them.

    I bought a Samsung Duo phone for personal use. I saw some cool apps for my phone on the Samsang website. I plug the Samsang Duo on to my netbook, but Ubuntu failed to see it. It tried Gnome and KDE with no avail. It is not a USB issue because the icon on my phone indict that it is charging.

    Is Ubuntu having trouble with cellphones dealing with Samsung or with cellphones in general?

    If this a driver issue, where can I get the drivers for Ubuntu so Ubuntu can recognize the Samsung Duo phone?
     
    Last edited: Sep 17, 2012
  2. ps355528

    ps355528 Regular member

    Joined:
    Aug 17, 2010
    Messages:
    1,005
    Likes Received:
    10
    Trophy Points:
    48
    it should see it as mass storage, but not always.. sometimes you have to set the phone into usb-debug mode.. I just connect to mine (j700) through bluetooth.. The only other samsung I have access to is a galaxy s2.. but that connects with sabayon 10 just fine..

    there is apparently something called "bitpim" .. no idea what that is but it has something to do with usb mass storage or whatever.. http://bitpim.org/help/

    this is a very samsung/ubuntu/specific hardware problem.. so probably ubuntu forums would be more help.. you are defo relying on somebody using ubuntu12 and that specific samsung phone.. which I'm not (10.04 and a j700.. no cable.. bluetooth)
     
  3. Schmick

    Schmick Member

    Joined:
    Apr 6, 2010
    Messages:
    51
    Likes Received:
    1
    Trophy Points:
    16
    With my new Galaxy S3, it doesn't have USB mass storage by default. I can only guess that might be the same sort of problem if it works on Windows but not Linux.

    I haven't tried it, but https://wiki.archlinux.org/index.php/MTP has some details on how you might get it running. There are also apps to activate UMS: http://androidadvices.com/enable-usb-mass-storage-option-samsung-galaxy-s3-tutorial/#.UFgnc7dYu00

    Not sure if it is the same problem you're having. I was peeved at first, but can understand why Samsung would do it - MTP means it doesn't have to dismount the drive to share it, so don't have to re-scan folders for changes. But its slower and not universally supported.
     

Share This Page