1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Video & Audio choppy when playing DVDs on laptop

Discussion in 'Nero discussion' started by grao5, Apr 8, 2007.

  1. grao5

    grao5 Member

    Joined:
    Oct 12, 2005
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    I was getting "Internal Error. Cannot build graph" error when trying to play DVDs using Nero Showtime 2 (Nero Express 6 suite) on my laptop built-in DVD ROM drive. So I changed Hardware acceleration to low under Display-> Settings-> Advanced and then managed to get rid of this "Internal Error" message and the DVDs are playing now. But the video & audio from DVDs' is choppy and they appear in frames.
    However I have no problem when playing CDs' in the same drive.
    I connected a Memorex 510L V1 external DVD burner to my laptop and faced the same problem when playing DVDs' while audio CDs' played fine. So this confirms it has to be something with my system ?
    Any inputs would be helpful.

    thanks
    waavman
     
  2. laddyboy

    laddyboy Regular member

    Joined:
    Jan 4, 2005
    Messages:
    4,188
    Likes Received:
    0
    Trophy Points:
    46
    Can you play DVDs with Windows Media Player, Media Player Classic, or any of the other players about? Showtime has its own set of problems apart from the others.

    As for the external drive, I assume your laptop has USB2 and not USB1. Is that correct?
     
  3. grao5

    grao5 Member

    Joined:
    Oct 12, 2005
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    Hi,
    I tried installing K-lite codec pack standard version and tried playing the DVD with the Media Player Classic that came with it. No luck . The video was exactly same like with Nero Showtime 2 -- choppy video and audio. My laptop has NeoMagic MagicMedia256AV+ display adapter and I installed the latest driver update from SONY for it so that I could try playing the DVD with hardware acceleration activated. But the moment I activate hardware acceleration and try to play the DVD Nero gives error "Internal Error. Cannot Build graph" while Media Player Classic just freezes.
    All the above tests were run using my SONY laptop's integrated DVD-ROM drive Toshiba SD-C2402. The external memorex DVD drive had the same problem yesterday so I guessed if I was not able to get the integrated SONY DVD-ROM drive to play smoothly today with Media Player Classic, it would be the same deal with the external drive too. So my goal is to get one working and then I think the other would too. So do you think the fact that I am not able to activate hardware acceleration is the reason for the choppy video/audio? Now that I have installed the latest driver update to the graphics card what else could I be missing ?

    thanks in advance
     
  4. laddyboy

    laddyboy Regular member

    Joined:
    Jan 4, 2005
    Messages:
    4,188
    Likes Received:
    0
    Trophy Points:
    46
    I'm not sure what's wrong. Could be the hardware, another application conflict, incorrect settings, etc.

    -Have you ever been able to play DVDs on this laptop?
    -Is this an older laptop or a new one?
    -If you could play DVDs before, was it before installing Nero?
    -What exact version of Nero 6 are you using? Nero 6.6.0.18 is the most recent stable version of Nero 6.
    -Have you tried uninstalling Nero and running the Nero 6 Clean Tool and then using WMP to play the DVD? If this works, you'll know Nero 6 is causing the problem.
     
  5. grao5

    grao5 Member

    Joined:
    Oct 12, 2005
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    Hi,
    Thanks for the suggestion. Mine is an old laptop with Win 98 SE. I t played DVD videos perfectly fine when I bought it but stopped for some reason a year ago. I installed Nero recently. Here's what happened since yesterday. Nero was giving the same "graph" error so I downloaded the 6.6.1.15a Nero update (package 2 and package 1) but still same error. Then continued trying with MPlayer Classic from the K-lite Std version. With h/w acceleration deactivated, I could not go beyond the DVDs' menu screen . With h/w acclrn enabled, mplayer classic played just audio from the DVD-video disc. So I uninstalled std version of k-lite codec pack and installed its full version. Now mplayer classic plays relatively smoother video (slightly choppy) with h/w acclrn disabled which is a slight progress. But if acclrn is enabled, mplayer classic says "Copyright protect error" at the bottom. On the other hand if I try to play on the memorex ext drive, homevideos that were recorded and finalized on DVD-RWs' on my JVC DRM-100S DVD recorder, mplayer classic has "Open Disc" option under File menu disabled. With DVD-video discs they are enabled. Hence for -RW I irectly go to Windows explorer under Memorex drive (F:) and click the .VRO dvd video file to open with mplayer classic. That plays my home video in slow motion. Do you know why the "Open Disc" option is disabled when I insert a DVD-RW ? Does it have something to do with the .VRO format as opposed to .VOB format ? And why does the video appear in slowmotion with choppy audio ? I admit mine is an old system but just curious why if it was working before its not now even with with popular tested codecs like K-lite etc. which all seem to hate it when I enable h/w acceleration. Anyway more +ve results with mplayer classic than Nero.

    thanks
     
  6. laddyboy

    laddyboy Regular member

    Joined:
    Jan 4, 2005
    Messages:
    4,188
    Likes Received:
    0
    Trophy Points:
    46
    I would save the data, reformat the hard drive, and reinstall the OS to get a virgin system and then go from there. While you could hunt for the problem maker, it'd likely take more time than just starting over. Unfortunately some of the older processors/systems didn't have a lot of horsepower and it didn't take much to make them choke. It's been so long since I've used Win 98, I don't remember the tricks, etc. anymore. Maybe someone else does.
     

Share This Page