1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

VirtuaDub Audio Problem

Discussion in 'MPEG-1 and MPEG-2 encoding (AVI to DVD)' started by Steven901, Nov 15, 2003.

  1. Steven901

    Steven901 Member

    Joined:
    Apr 3, 2003
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    16
    K first I tried to convert an AVI to mpeg with TMPGenc...and there was no audio, so I followed a guide made by Dela, and tried running the file through VirtuaDub and saving it as a new avi....After that, I ran the new AVI through tmpgenc,the audio worked but was out of sync by about 3 seconds.....Can I ask what I did wrong, and can anyone please tell me how to fix the problem?
    Thanks
    Steven
     
  2. Minion

    Minion Senior member

    Joined:
    Sep 28, 2003
    Messages:
    5,768
    Likes Received:
    0
    Trophy Points:
    116
    Well the Audio in your AVI was Probably VBR MP3, and you don"t Have to make a New AVI file you just need to extract the audio to Wav format and use the Wav audio as the audio source in Tmpgenc...So Load your AVI file into Virtual Dub and go to "file" to "File information" and Make sure that the audio length and the Video length are the same or at least very Close...Then set the audio to "Full proscessing Mode" then under "Compression" set it to "None" then go to "File" to "Save Wav" and save the File...Now run Tmpgenc and Load your AVI file in for the Video, and the Wav file for the Audio and encode to Mpeg...You audio should be in sync....Cheers
     
  3. Steven901

    Steven901 Member

    Joined:
    Apr 3, 2003
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    16
    I just tried it, and the audio was out of sync again...what do i do if the audio and video are not the same length....what then?
     
  4. Minion

    Minion Senior member

    Joined:
    Sep 28, 2003
    Messages:
    5,768
    Likes Received:
    0
    Trophy Points:
    116
    Well if the audio and Video are Different lengths then that is most likely the cause of the Sync Problem and what you could do is Strect/Shrink the audio to the exact length of the Video useing a good audio editor like "Goldwave"...What it basicly does is speed up or slow down the audio a tiny bit so that the length is slightly longer or shorter..I use this method when converting Pal to NTSC and it works great...So go and download Goldwave from this page http://www.goldwave.com/release.html
    then Find out the exact length of the Encoded Mpeg Video file(if the sync problem happens after encodeing then you should use the length of the file after encodeing to mpeg) and write down the length exactly, Then run Goldwave and load in the Wav audio file you extracted from the AVI file and then go to "Effects" to "Time Warp" and choose the First time warp option and then type in the Length of the Mpeg Video file(If it is Mpeg1 you can find out it"s length useing virtual dub) in the space provided and then render the file as a new Wav file..Now you just need to encode the Wav file to Mpeg1 Layer 2 audio and Multiplex it with the Mpeg Video file and then the File should be in perfect Sync...Just keep your Fingers Crossed...I just Hope that goldwave will render projects in demo mode, if not then message me and I"ll try to find a freeware audio editor that will do this....Good Luck
     

Share This Page