1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Window7 Toshiba Laptop won't play Youtube videos

Discussion in 'Windows - General discussion' started by philbert1a, Aug 19, 2012.

  1. philbert1a

    philbert1a Member

    Joined:
    Jun 27, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    I have a Toshiba laptop running Win7; recently it won't play any videos on Youtube, giving me error messages and a static filled Youtube screen. Yet, my Samsung Galaxy plays the same YT video as does my ancient XP OS PC.
    I know there is something weird on mylaptop, but I have no idea why this is happening. Can anyone help ? I know I'm not the very first to have this happen, but I am among the more ignorant people out there when it comes to Win7.
    I liked Win98, I'm that retro.
     
    Last edited: Aug 20, 2012
  2. ddp

    ddp Moderator Staff Member

    Joined:
    Oct 15, 2004
    Messages:
    39,011
    Likes Received:
    77
    Trophy Points:
    128
    was it able to play before? was there an update recently for win7 that included video driver?
     
  3. philbert1a

    philbert1a Member

    Joined:
    Jun 27, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    It did indeed play (great) before, I usually go to my laptop for good YT vid playback, so yes. I don't have it set for automatic updates, but Win7 may do that on it's own. I don't know.
    To be more specific, the Youtube screen is intact, but when I click on the play arrow on the vid the vid square goes snowy on the youtube screen...sometimes I get a Youtube error message that says to try again later.
    Which is weird 'cause at the same moment I can view the vid on my old PC, w/XP OS, AND my Samsung Android phone.
     
    Last edited: Aug 20, 2012
  4. ddp

    ddp Moderator Staff Member

    Joined:
    Oct 15, 2004
    Messages:
    39,011
    Likes Received:
    77
    Trophy Points:
    128
    try system restore to before problem started to see what happens as i think your video driver was updated on you whereas you do not want the ms video driver..
     

Share This Page