1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

All of a sudden...

Discussion in 'DVD / Blu-ray drives' started by klbinphx, Jul 23, 2003.

  1. klbinphx

    klbinphx Guest

    ....my Sony DRU-500A says, via WinXP Home, that 'no disk is inserted', when I put a Ritek G04 4X disk in the tray. Can't figure out why. Am trying to use DVDXCopy or DVDXpress to back up a DVD. Can't recall having this problem before, and recall burning the G04s with my 2.0f firmware upgrade. Any ideas out there. Where am I screwing up? BTW CD DVD Decrypter and Nero Info Tool give me the same results. Same results on Meritline's 4X disks.
  2. Tosca

    Tosca Guest

    have you tried other blank media?

    You sure they are G04's?
  3. klbinphx

    klbinphx Guest

    Yes, have tried some bogus Accu '2X' too. While awaiting BB repsonses, I have backward 'burned' (!) Sony's v.2.0e 'firmware' upgrade. Was using 2.0f. Amazingly, both DVD Decrypter and infoTool now read the G04s from Supermedia, and still reject the G04s from Meritline. Very, very disappointed with Meritline. BTW, they have stiffed me on last two purchases with bad blanks. No more. Still puzzled, but will stick with 2.0e, hoping that that was the problem.

Share This Page