1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem Android TV Box Bricked-Can't get to recovery mode

Discussion in 'Android TV boxes (Kodi, XBMC, etc)' started by Camaro99, Apr 13, 2020.

  1. Camaro99

    Camaro99 Member

    Joined:
    Feb 22, 2003
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    Hi all,
    I have a EASYTONE Android 9.0 TV Box (T9). I had in a drawer for a few months and went to turn it on and nothing. No lights or text on the front panel, however the T9 logo does come up on the TV when I plug it in.
    I've tried resetting it pressing the reset button and plugging in power but I cannot get to recovery mode to do a factory reset.
    I've been digging, but I'm not sure what to do now. Any advice?? I reached out to the company's tech support but nothing.
    Thanks!
     
  2. Camaro99

    Camaro99 Member

    Joined:
    Feb 22, 2003
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    So about 150 people viewed this, but no suggestions on how to resolve this? I guess I'm throwing the thing away LOL
     
  3. wither 1

    wither 1 Regular member

    Joined:
    Nov 29, 2019
    Messages:
    607
    Likes Received:
    21
    Trophy Points:
    28
  4. wither 1

    wither 1 Regular member

    Joined:
    Nov 29, 2019
    Messages:
    607
    Likes Received:
    21
    Trophy Points:
    28
    Did that help you?
     

Share This Page