1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Ati x1950 pro issue

Discussion in 'Building a new PC' started by drako17, Feb 9, 2008.

  1. drako17

    drako17 Regular member

    Joined:
    Oct 28, 2007
    Messages:
    225
    Likes Received:
    0
    Trophy Points:
    26
    ok to start things off. i've been trying to overclock this card. after about 3-5 mins of game play the screen goes blank and it goes back to normal. when i exit the game i see where is says the driver has failed and has recovered. when i check the overclock. its back to normal. i set this card at 600 core clock and 725 memory clock. i've tried different timings with the same result. any help would be appreciated
     
  2. sammorris

    sammorris Senior member

    Joined:
    Mar 4, 2004
    Messages:
    33,336
    Likes Received:
    6
    Trophy Points:
    118
    If you use the latest version of catalyst you can automatically find the most stable overclock by either using autotune or setting a clock frequency and having it tested.
    Which brand X1950Pro have you got? If it's a Powercolor, Gecube or Connect3D one you may potentially have issues, those cards were never very good. If it's a Sapphire or HIS one you should be alright. Check that the card isn't overheating, also using catalyst.
     
  3. drako17

    drako17 Regular member

    Joined:
    Oct 28, 2007
    Messages:
    225
    Likes Received:
    0
    Trophy Points:
    26
    i've tried that already. it keeps doing the same thing. the core and memroy clocks keep dropping until its back to its default. the driver keeps failing and recovering. i have the latest driver. 8.1 and i've had this issue with this card ever since i first got it. i had windows xp and it did the same thing. now i have windows vista ultimate. with the same results. i dont know who made it. it just said ati radieon x1950 pro 256mb
     
  4. sammorris

    sammorris Senior member

    Joined:
    Mar 4, 2004
    Messages:
    33,336
    Likes Received:
    6
    Trophy Points:
    118
    Look on the original invoice perhaps?
     
  5. drako17

    drako17 Regular member

    Joined:
    Oct 28, 2007
    Messages:
    225
    Likes Received:
    0
    Trophy Points:
    26
    could you be a bit more specific on the invoice part?
     
  6. sammorris

    sammorris Senior member

    Joined:
    Mar 4, 2004
    Messages:
    33,336
    Likes Received:
    6
    Trophy Points:
    118
    Well, whatever documentation you got when you bought the card...

    I'm off to a LAN party in a moment, so I'll get back to you again when I'm all set up, probably be a couple of hours...
     
  7. drako17

    drako17 Regular member

    Joined:
    Oct 28, 2007
    Messages:
    225
    Likes Received:
    0
    Trophy Points:
    26
    i've owned this card for some time now. i dont have any invoices or documents. i threw away the box and every paper that came with it. so now i only have the card.
     
  8. drako17

    drako17 Regular member

    Joined:
    Oct 28, 2007
    Messages:
    225
    Likes Received:
    0
    Trophy Points:
    26
  9. sammorris

    sammorris Senior member

    Joined:
    Mar 4, 2004
    Messages:
    33,336
    Likes Received:
    6
    Trophy Points:
    118
    If the problem occurs with different OSes and different drivers it sounds like a hardware problem... Think it may be time for you to get a new GPU...
     
  10. DXR88

    DXR88 Regular member

    Joined:
    May 29, 2007
    Messages:
    714
    Likes Received:
    2
    Trophy Points:
    28
    i have the same card, in an CrossFire setup, however my screen dosent go blank it just laggs like hell. i think it has somthing to do with the new driver, also uncheck were it says VPU Recover as this is an ATI Overclockers nightmare. also CHECK to see if Support DXT Texture Formats is unchecked if it is check it.

    if that does not help then im afraid sammorris may be right
     
  11. drako17

    drako17 Regular member

    Joined:
    Oct 28, 2007
    Messages:
    225
    Likes Received:
    0
    Trophy Points:
    26
    well i was thinking of getting the 8800gt. its 250 now. ill try what you all suggested. ill let you all know how it goes. thanks i will be back.
     

Share This Page