1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Corrupted avi still plays on Virtualdub and Avidemux but no longer plays on VLC / Windows Player.

Discussion in 'Video playback problems' started by Gotanno, Apr 21, 2018.

  1. Gotanno

    Gotanno Newbie

    Joined:
    Apr 21, 2018
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I have several camcorder captures on my hard drive (.avi Huffyuv), that I was planning to edit and transcode into lighter formats at a later time. I would like to keep these files in AVI format using either Huffyuv or Lagarith.

    All was going well until I got a disk error and foolishly ran chkdsk (with repair enabled). Result: I got access to the folders again but all my captured files have gone nuts. They play fine in VLC up until about 11 minutes and that's when they go psychedelic (wildly alternating Green / blue/ yellow / red / purple boxes and stripes and "snowy" sound too). The interesting thing here is that every single file plays fine up until about 11 mins, regardless of how long they are.

    The files play normally on Virtualdub and Avidemux

    I've tried transcoding (if that's the right word) in Virtual (direct stream copy, fast recompress, normal recompress and full processing - this last option provided best results but the file is still unwatchable) but they still come out blocky when played in VLC. Same results with Avidemux

    Windows media player will only play sound and haven't tried other players, but I think they will most likely also throw up errors.

    What can I do? Any ideas?

    I have saved the chkdsk log and I can also upload samples of the videos on here.

    Thanks
     
    Last edited: Apr 21, 2018
  2. attar

    attar Senior member

    Joined:
    Jun 17, 2005
    Messages:
    11,536
    Likes Received:
    30
    Trophy Points:
    128

Share This Page