1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

no subtitles showing on wdtv live media player

Discussion in 'Media tanks' started by rebelx2010, Feb 19, 2011.

  1. rebelx2010

    rebelx2010 Member

    Joined:
    Feb 19, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    11
    I've been ripping blu-ray movies using dvdfab hd and makemkv with subpicture/subtitles checked respectively. Played back on my wd media player but no subtitles are showing even though I pressed OPTION on the remote control and chose SUBTITLE. My wd media player is hooked to to my led tv via hdmi cable. Can someone tell me please why no subtitles are showing? Thanks in advance.
     
  2. dRD

    dRD I hate titles Staff Member

    Joined:
    Jun 10, 1999
    Messages:
    8,745
    Likes Received:
    157
    Trophy Points:
    143
    I suspect that WDTV Live has the same issue as many other "media tanks", i.e. they don't support other than .srt formatted subs when they're built into the video file itself. This means that your best bet is to re-rip the movie, without having the subtitles built-in to the video and rip the subtitles separately into .SUP files.

    After that, run the .SUP files via SupRip which will allow you to convert the .SUP files (subtitles are pictures, you need to "teach" the program how to convert them into text) to standard .srt files. Then, simply, rename the .srt file to match your video file (i.e. you have video2.mkv and video2.srt files in same folder).

    Had the same issue with my Popcorn Hour -- just having separate .srt file wasn't enough, I had to remove the built-in subs from the .mkv file as well before it started working properly.
     

Share This Page