1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

philips dvdr70 error reading dvd9 backups

Discussion in 'DVD recorders' started by jd1968, Feb 1, 2005.

  1. jd1968

    jd1968 Guest

    Hello, I just succesfully made 3 backups of a dvd in 3 different ways: using dvd decrypter, dvdshrink, anydvd with nero 6. Every dvd player that I tried reads correctly all 3 dvd9 backups that I made, only my philips dvdr-70 doesn't, quite funny. My burner is philips 1940P with the lastest firmware release 3.2. Can someone give me some advice?

  2. know1190

    know1190 Guest

    I have the same dvdr70 and allways use Anydvd and nero 6 recode and never have a problem but it may be the media your using, the machine might not be happy with.
  3. jd1968

    jd1968 Guest

    Hi, it could be but I use verbatim and I tried to play dvd9 with samsung, sony, nortek and another couple of brands tha I don't remember now and they have no prboblems playing the dvd9 so as far as I've experienced in past it seems that is the player. It could be the media but I can't find another brand on the market right know I have to wait. I'm in contact with philips assistance for this problem...hope new version of firma could solve the problem...thanks for the idea and if you any other information please let me know.


Share This Page