1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Plextor PX-755SA locks up computer

Discussion in 'DVD / Blu-ray drives' started by disrupt, Mar 11, 2007.

  1. disrupt

    disrupt Guest

    Hello all. I am having a problem with my new Plextor PX-755SA. Everytime I insert a cd or dvd into the drive, it locks up my computer. Therefore, I have to manually reboot to start up Windows again. I also reformatted my hard drive (Western Digital Raptor 36.7GB) which is where XP is installed, before I tried using this. I don't have Nero installed by the way because I read on another forum that it intefere's with the drive.
    I am completely lost and cannot figure this out. Thanks to all who contributes to help!

    Here are my specs:

    AMD Athlon 64 3200+ 2.01 Ghz
    Plextor PX-230A (IDE CD Drive)
    Plextor PX-755SA (SATA CD/DVD Drive)
    1 Western Digital Raptor 36.7GB (SATA HD)
    2 Maxtor DiamondMax10 300GB (SATA HD)
    Corsair XMS 1GB (2 x 512 MB) PC3200
  2. disrupt

    disrupt Guest

    Oops! I forgot to mention in the video card in the specs:

    1 XFX GeForce 6800GT 256MB PCI Express

    if that helps.
  3. Fwfireman

    Fwfireman Member

    Feb 16, 2007
    Likes Received:
    Trophy Points:
    First, look in Device Manager and see if your Plextor is even there then make sure you have the latest firmware from Plextor. It's 1.07 for the 775 which I have.

    Here are a few things to try after the above. Taken from a tech forums:

    1] In Device Manager, look open IDE ATA/ATAPI controllers.
    Look for the one that says "Serial ATA Storage controller.....uninstall this and then reboot....this allows windows to reinstall the drivers for the SATA controller. Solves many problems to begin with. If that doesn't work.....

    2]Go to My Computer, right click on your CD and/or DVD drives, go to Properties, select the AutoPlay tab and select "Prompt me each time to choose an action" at the bottom. This way you can stop any of these horrid albums from running their copy protection programs when you insert a CD or DVD. Insert a CD or DVD and try using a different player. See if it works, if it does then it's the software player. Try WMP, Quick Time or Real or any that you have. Note which ones it works in and which it don't. The ones that don't work, remove and reinstall. If it still won't work, you will have to remember and use the player that works with that CD or DVD.

    3]Try searching your computer for file "autorun.inf". Others have suggested removing, don't delete yet but put in a safe place. See if problem is solved. If it is, delete autorun.inf.
    "Some copy protected CDs (i.e. Cactus Shield) have an autorun.inf file that automatically installs some copy protection related app on your machine (that's why i turn off AutoPlay on all my drives."

    Disable "Auto Play" on that Plextor or at least have it prompt you as suggested above.

    4] " This is a tough one! My first reaction was to assume that there's something physically wrong with the drive, but I asked a few PC hardware experts for their opinions too. Here's what I got back:

    "I am guessing, but here's what I'd do: take off the CDROM drive and run the computer for a bit to see if the problem goes away. Make sure that all the jumpers on the drive are properly set and that the BIOS reads the devices as "auto". Check IDE cabling too, perhaps something was pinched or frayed? This really doesn't sound like a software error, more like BIOS / Hardware reporting errors."

    The second opinion (see, just like doctors):

    My first guess is that it is time to replace that drive. Sounds like the reader is off just a bit. Could be that the user is just having trouble with burned cd's, but sounds like having trouble with all disks.

    User can try a few things before giving up on that drive though.

    1. To solve hang on boot

    Move the CDROM behind the hard drive on the boot order

    2. To solve freezes on drive reads

    Update the driver from manufacturer


    Change the windows read ahead method

    But again, sounds like need new CDROM drive."

    Those are a few I found on the internet doing a Google search.

    Good Luck


Share This Page