1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Power Issues Resolved

Discussion in 'Xbox - Hardware mods' started by SProdigy, Feb 9, 2007.

  1. SProdigy

    SProdigy Regular member

    Jan 24, 2007
    Likes Received:
    Trophy Points:
    Here is a quote from a post I made in the softmod thread around a month ago:
    Hi guys. I'm in a bit of a quagmire. I used this method roughly 6 months ago to upgrade to a 120gb Seagate drive. Everything went smooth as planned. Just the other day I turned on my Xbox and got the "Error Code 07 - Service Needed" screen. I pulled my 120gb drive out and imaged it again using XboxHDM, and tried once more to no avail.

    I have 3 of these drives, and tried another one, using all the same methods and still get the 07 Error Screen. However, I popped in the original Xbox WD 10gb drive and the system boots into UnleashX with no problem.

    I can hear/feel the WD drive power on, however, I cannot with the Seagate drives. I've run diagnostics tests on both Seagate drives and they pass with no issue. Has anyone else run into a problem like this? I've seen that "07" could be related to the power supply, but why would the stock drive power up and not any of the others?
    Within the last few days, my Xbox would not even power on at all, stock drive or not. It was a door stopper. However, I found this solution on LLamma's forum:
    You have corrosion on the power traces that sit at the front of your motherboard!

    Completely disassemble your xbox, remove the MB, flip it over and look at the traces that run the length of the front of the board! If they have little black\grey\green bumps on them, you need to clean them! I normally use a small flatbladed screwdriver and run the length of the trace. This will normally fix your problem! Here's a pic of one I fixed yesterday...


    Your motherboard may look different but you get the idea, look for corroded traces, this IS your problem!
    Indeed, all I had to do was flip over the power supply and look at the circuit board, and there was a corroded trace on it! Took some isopropyl and a precision flat head screw driver, scraping and cleaning the corrosion away.

    After it was cleaned up, I popped everything together and BINGO! we have power and a fully functional Xbox again. I re-imaged my 120gb and reinstalled it, and everything works perfectly as before.

    I remember looking all over the web for insight on how to fix this error and I was seconds away from purchasing another power supply. I thought I would make this information available to everyone, in the event they have a similar problem as mine, then this may help them save some time and money.

Share This Page