1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

problems with aopen 16x dvdrom drive

Discussion in 'DVD-ROM drives' started by c0nspire, Sep 16, 2004.

  1. c0nspire

    c0nspire Member

    Sep 16, 2004
    Likes Received:
    Trophy Points:
    Hello, i am having problems with my aopen drive. It is able to read media that is on any regular cdr but is unable to read dvd's of any kind.

    ive tried updating and downgrading the firmware, ive tried to uninstall and reinstall the aspi layer and ive also tried remopving the device and reinstalling it.

    Does anybody have any ideas??

    oh by the way when i insert a dvd i just get a "there is no disc in the disc drive message"

  2. Nephilim

    Nephilim Moderator Staff Member

    Feb 13, 2003
    Likes Received:
    Trophy Points:

    It may help to unistall the device through Windows. Try this:

    Go to Device Manager >

    Expand the tree for DVD/CD ROM Drives >

    Find the drive in question, right click it and go to Properties >

    Under the Driver tab, select Uninstall then OK.

    Now reboot and Windows should detect and reinstall the drive.

    If this doesn't help try the same steps as above except expand the tree for IDE ATA/ATA Controllers and uninstall either the Primary or Secondary controller depending on which one the drive in question is attatched to. Nero Info Tool can tell you which chain the drive is on under the Configuration tab.


Share This Page