1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RAID 0 and defrag question

Discussion in 'PC hardware help' started by Divinus, Dec 10, 2004.

  1. Divinus

    Divinus Guest

    All right, this question goes out to all of you who use a striped array.

    I have 2x60GB Maxtor SATA HDDs. I run them in RAID 0 via my onboard SATA Raid Controller (Abit NF7-S Rv2). My problem is, I can't defrag nor run any kind of checkdisk on this configuration. When I try to run defrag, it sits there at 0% for hours on end. I tried installing Diskkeeper and I get the same activity. Tried running disc check and I get something telling me it needs to access all files and to restart (even when I reboot it gives me the same). I may just boot into DOS and run chkdsk on it.

    I heard from somewhere that if you cluster size is anything different than 4k (mine is 16k) that you'll have problems with defragging software. I was also going to flash my bios last night seeing as they have an updated raid controller version but the damn floppy disk I have must be bad (keep getting I/O errors on startup).

    Oh yeah, on more strange scenario I recently had that I was hoping someone could shed some light on. To really understand this I'll have to tell you how it happened like a story, so bear with me.

    My system details are at the bottom, do you get an idea of what I have. I used to have 2x512MB Mushkin PC3200 sticks. I had the two drives set up perfectly and everything was fine. I started getting strange crashes to the desktop and this is while my system was OCed, so I backed off the FSB and kept getting them. I noticed that my system was failing the POST memory test. I pulled out both of the 512MB individually and one of them at least appeared to be bad (as I would get no memory test failure and no crashing programs in Windows when it was out). Here's where the weird part comes in. Soon afterward, I took this module to a friend's house and it works perfectly fine in the computer I built for him (MSI Ktv4 board). I'm thinking that chip just can't handle the FSB, so I take it home and stick it back in, lower the FSB and my memory failure goes away. I decide to wipe the slate clean and reformat. Get through the XP setup and the first time it goes to boot from the HDD, I get nothing. Nodda, just a black screen. I'm guessing there is a problem with the memory, so I pull the stick out and it boots fine. I'm really needing this 512 stick because at the time I'm into SWG and this game is one huge memory eating hog. This is where is gets really weird. After playing with my drives, I noticed that with both memory sticks in, I could boot from Windows fine as long as I didn't have them in a RAID array (mirrored or striped). I'd have to physically unhook one drive or the other and install windows on only one HDD. Windows booted fine, no memory failures...problems, etc... Although, as soon as I hooked the other HDD back up and put them in a RAID array, tried to install XP on the array... same old crap. No boot at all from the SATA controller. I tried calling A-bit at one time, but I got some arabian guy who couldn't understand what I was saying (and I couldn't understand him). He just kept blaming it on Windows, so that was the end of that. Sorry if I'm rambling, but this is just very strange to me that this memory stick works perfectly fine when the HDDs are not in a RAID array, but when you put them in an array it goes nuts all over the place. It can also be said that the HDDs function fine in their array without that stick in (which is how I have it now).

    Strange, eh? Any ideas?
  2. steblade

    steblade Member

    Dec 10, 2004
    Likes Received:
    Trophy Points:
    I use a raid array but I dont think thats got anything to do with your problem, sounds like there is a problem with your config and its not windows. I would start by checking on your mobo's site for bios updates, dont just update though see if there's anything that relates to your hardware, ive had problems like this and you would not belive what it turned out to be. Have you tried running the hdds as a mirror array? Or just having your raid contoller in a non raid mode, if you think the cluster size is causing problem then get power quest partition magic 8, its exellent tool, it can resize your clusters without loosing data, please post your findings
  3. Divinus

    Divinus Guest

    I did try running them in a mirrored array, but it turned out the same as in the striped array, no boot into windows :(

    I did, however, skim across something on the A-Bit forums about a problem with the raid controller conflicting with something else and not starting windows. I'm about to flash my BIOS to the latest manufacturer update. Just as soon as I can get my fat fingers in there to make sure I can switch the cmos jumpers and clear it :) lol.

    Thanks for the help Steblade, I appreciate it. I will most certainly report what happens back here after the flash.
  4. Divinus

    Divinus Guest

    Ok, still no luck.

    Flashed the BIOS to the newest version. Still the same weird crap. I'm convinced maybe the RAID just is more picky in booting than IDE... It has to be.

    With the other 512 Stick in, No windows boot at all from the RAID Array. Albeit, with an IDE hard drive in, it books perfectly fine. And with only one 512 stick in, I get a perfect boot from the RAID Array, bah... who knows.

    As with my original question... I still can't format or anything, so I'm probably going to change the size with the program you suggested.

    Thanks again.
  5. rroettger

    rroettger Regular member

    Sep 3, 2004
    Likes Received:
    Trophy Points:
    Are you refering to the block file size? The minimum size for a file. My system has a defualt size of 64kb, but I use 128kb. It is suppose to be better for handling video edits.

Share This Page