1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Windows Media Player cant resize video to fit entire screen

Discussion in 'Video - Software discussion' started by bass3p, Dec 9, 2008.

  1. bass3p

    bass3p Member

    Joined:
    Dec 9, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    11
    when playing videos in windows media player i am unable to resize the video so that it can fit the entire screen. at the moment, when i play a video it will be in the center with a black vertical border surrounding it, the border is massive taking about 1/6 of the window. this didnt happen before and only happend recently, i dont know why and it isnt with just a single video. the problem does not occur with MPC but i really prefer wmp over mpc and dont really want to change players. does anyone know a plugin/way to change the aspect ratio of the video so that it will fit the entire screen automatically regardless of what size the original video is? I've tried the video resizing options; fit to player, fit to video, 200% size but they dont fix the problem. any help is appreciated, thanks in advance.
     
  2. millargh

    millargh Member

    Joined:
    Dec 11, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    I have the same problem . I dont want a different player i just want windows media player 11 to play them at full size without having to uncheck and then check "fit video to player on resize" every bloody time lol. I know there is a fix for this i just cant remember how to do it as it has been a very long time since i have needed to . any help would be appreciated.
     
  3. maxikaz

    maxikaz Member

    Joined:
    Dec 2, 2008
    Messages:
    77
    Likes Received:
    0
    Trophy Points:
    16
    the only way to fix this problem is change the video player
     
  4. Peshtigo

    Peshtigo Regular member

    Joined:
    Sep 15, 2008
    Messages:
    635
    Likes Received:
    0
    Trophy Points:
    26
    Why don't you just hit the "Full Screen" icon in the bottom corner and hit "Escape" to switch back (on WMP 11). Mine works perfectly.
    Some people are fixers, some people are...avoiders. To each their own.
     
    Last edited: Dec 11, 2008
  5. millargh

    millargh Member

    Joined:
    Dec 11, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    I am here looking for a solution to my problem not a way around it. .Full size is different to full screen and thats what i want . I dont want a new player as i already have vlc for what windows media player wont play.
     
  6. scorpNZ

    scorpNZ Active member

    Joined:
    Mar 23, 2005
    Messages:
    4,166
    Likes Received:
    47
    Trophy Points:
    78
    If full size & full screen to you are not one & the same then what are they,could'a sworn both mean to fill whole viewing area & did you try it if so what happened,unless you meant to say full size windowed

    Try this
    start wmp,don't pay video,right clik on "now playing tab",click on "more options",click "performance tab",click "advanced button",tick any box that is free then hit ok ,then click restore defaults which is next to the advanced button,apart from those video settings there does'nt seem to be much else one can do as those default settings should play the vid as you want it,the only lines i see are horizontal,the only time i see vertical lines is when i'm using xbmc windows version then it's just a matter of changing the view from xbmc settings




     
    Last edited: Dec 12, 2008
  7. Peshtigo

    Peshtigo Regular member

    Joined:
    Sep 15, 2008
    Messages:
    635
    Likes Received:
    0
    Trophy Points:
    26
    I wasn't referring to you. You seem to be trying to fix your problem, unlike some others that rush to a different app whenever they find a glitch in the old one. I prefer to eliminate the glitch.
     
  8. bass3p

    bass3p Member

    Joined:
    Dec 9, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    11
    if i go into full-screen mode there will still be the video centered in the middle with a massive vertical black border on each side that takes about 1/3 of the screen which is annoying. the problem is that the video is not at full-size; windows media player does not resize the video so that, for example, a 600 x 400 sized video will change into the correct size that will fill up the entire screen, leaving no black borders. many other players like zoom player have an aspect ratio option for the video that is "fit to screen" which resizes it, unlike a video played in wmp which is shown at a 600 x 400 size in a 1000 x 700 screen, resulting in black borders; this is what i think, not really sure. i really dont want to switch players either since i know that theres a option/fix for it too since i had no problem with the video size as it fit the entire screen before. i think what triggered it to not resize videos was that i was playing Left 4 Dead and when i exited the game, the game changed my display settings to an extremely low screen resolution and when i changed back to my original resolution i noticed the weird black borders on videos in wmp.
     
  9. scorpNZ

    scorpNZ Active member

    Joined:
    Mar 23, 2005
    Messages:
    4,166
    Likes Received:
    47
    Trophy Points:
    78
    That would mean wmp is used by the game to display,check settings in the game if there's nothing in wmp that you can find,bass3p if you're going to use the comp as a media centre or view movies & play music,yod're best bet would be to install xbmc for windows it totally blows all other media players out of the water,even the 360 should've had it instead of the in house built
     
    Last edited: Dec 15, 2008
  10. kisrella

    kisrella Member

    Joined:
    Feb 3, 2009
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    11
    I just got this problem and found a REAL solution. It seems that closed caption was turned on. Thus creating the 1/3 black border on the bottom of the screen. The fix:
    Turn off the captions. Go to Play-Lyrics,Captions and Subtitles- Off.
    Hope this helps.


     
  11. millargh

    millargh Member

    Joined:
    Dec 11, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    kisrella that didnt work for me as my captions in windows media player 10 are already off . Its really annoyiung because i did know how to do this but i just cant remember as it was so long ago . Anyway let me know if you think of some thing else that might help
     
  12. Stellage

    Stellage Member

    Joined:
    Mar 2, 2009
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    11
    I had the same problem, but found the solution.
    In the WMP 10 menu click on View, then way down " video size"
    Check "resize video to player on resize"
    Uncheck "fit player to video on start"

    That should do it!
     

Share This Page