1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Windows XP Home Labtop Dead due to missing registry files

Discussion in 'PC hardware help' started by LufianGuy, Sep 17, 2011.

  1. LufianGuy

    LufianGuy Regular member

    Jan 21, 2006
    Likes Received:
    Trophy Points:
    I haven't been on in a very long time and wish everyone the best.

    So lets get down to the problem:

    I come home and my dad says the labtop isn't working. Old dell labtop (think 2005) that has a windows product key sticker that says dell on its bottom.

    I turn it on, windows seems to do fine but the login screen is always black and I had to turn the computer off.

    So I tried to boot into safe mode and got this blue screen message:
    "STOP: c0000218 {Registry File Failure}
    The registry cannot load the hive (file):
    or its log or alternate.
    It is corrupt, absent, or not writable

    Beginning dump of physical memory,"

    So I used a dell xp home sp3 cd (don't have the original cd) to get to windows recovery console. I ran chkdsk /r on Wednesday hoping to fix the problem.

    While chkdsk /r was running the harddrive started to make clicking noises and progress went down from 75% to 50% while it was running.

    When it finished today (Saturday) it was 75% complete and said something about 1 or more unrecoverable errors on the disk.

    I exited the console and tried to boot windows normally, and it is telling me it is missing another registry file and tells me to do a repair.

    I tried to go into safe mode after that, it stays on screen (doesn't go to a blue) and tells me:
    "Windows could not start because the following file is missing or corrupt:

    you can attempt to repair this file by starting Windows Setup
    using the original Setup CD-ROM.
    Select "r" at the 1st screen to start repair."

    1. I just tried to do chkdsk /r to fix the problem, should I try again with chkdsk /p or /f?
    (chkdsk /r implies /p,/f, so I'm afraid this won't work)

    2. Would a clean install of windows fix this issue?

    3. Is there a better way to fix this issue than a clean install or is there something I have overlooked?


    Steps I might need to take:
    1. Run the HDD Manufacturers diagnostic utility (Will have to find out who made the HDD and how to make a bootable cd for it):
    Last edited: Sep 17, 2011
  2. attar

    attar Senior member

    Jun 17, 2005
    Likes Received:
    Trophy Points:
    Last edited: Sep 17, 2011
  3. ddp

    ddp Moderator Staff Member

    Oct 15, 2004
    Likes Received:
    Trophy Points:
    i think your hard drive has developed bad sectors.

Share This Page